pkgsrc/print/py-weasyprint0/patches/patch-setup.py
kleink cb6b0b90a2 print/py-weasyprint0: Import WeasyPrint 0.42.3.
NOTE: This package caters to Python 2.7 environments, support for
      which was dropped in subsequent releases.


WeasyPrint is a visual rendering engine for HTML and CSS that can export
to PDF. It aims to support web standards for printing.
WeasyPrint is free software made available under a BSD license.

It is based on various libraries but *not* on a full rendering engine like
WebKit or Gecko. The CSS layout engine is written in Python, designed for
pagination, and meant to be easy to hack on.
2018-11-16 14:12:42 +00:00

15 lines
483 B
Python

$NetBSD: patch-setup.py,v 1.1 2018/11/16 14:12:42 kleink Exp $
Adjust script path to allow multiple Python version installs.
--- setup.py.orig 2017-12-22 23:26:45.000000000 +0000
+++ setup.py
@@ -83,7 +83,7 @@ setup(
':python_version >= "3.0"': ['CairoSVG >= 1.0.20']},
entry_points={
'console_scripts': [
- 'weasyprint = weasyprint.__main__:main',
+ 'weasyprint%s = weasyprint.__main__:main' % sys.version[0:3],
],
},
)