026fef7428
pkgsrc changes: no longer automatically generate the PLIST. use (de)install templates for handling updating the index files when adding/removing R packages. Changes 2.4.1 This is a maintenance release and fixes a number of mostly minor bugs. Changes 2.4.0 This release has many new features. One important aspect is that S4 classes now have their own internal type, and S4 method dispatch has been completely revised to using cached generic functions, giving substantial performance improvements. As a consequence, all packages depending on "methods" need to be reinstalled.
13 lines
632 B
Text
13 lines
632 B
Text
$NetBSD: patch-ad,v 1.11 2007/03/14 11:50:35 markd Exp $
|
|
|
|
--- src/main/Makefile.in.orig 2006-09-05 02:41:33.000000000 +1200
|
|
+++ src/main/Makefile.in
|
|
@@ -104,7 +104,7 @@ COMMON_DEPENDENCIES = \
|
|
R_binary = R.bin
|
|
R_bin_OBJECTS = Rmain.o @WANT_R_SHLIB_FALSE@$(OBJECTS)
|
|
@WANT_R_SHLIB_FALSE@R_bin_LDADD = $(RLIBS) $(EXTRA_LIBS)
|
|
-@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ -lR @BLAS_SHLIB_TRUE@-lRblas
|
|
+@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ ${COMPILER_RPATH_FLAG}$(Rexeclibdir) -lR @BLAS_SHLIB_TRUE@-lRblas
|
|
R_bin_DEPENDENCIES =@WANT_R_SHLIB_FALSE@ $(RLIBS) $(COMMON_DEPENDENCIES)
|
|
|
|
libR_la = libR$(DYLIB_EXT)
|