pkgsrc/lang/pict/patches/patch-af
dholland 8b563c8055 Initial import of Pict 4.1 into the NetBSD package system.
Pict is a language in the ML tradition, formed by adding a layer of
convenient syntactic sugar and a static type system to a tiny
core. The current release includes a Pict-to-C compiler, reference
manual, language tutorial, numerous libraries, and example programs.

The core language - an asynchronous variant of Milner, Parrow, and
Walker's pi-calculus - has been used as a theoretical foundation for a
broad class of concurrent computations. The goal in Pict is to
identify high-level idioms that arise naturally when these primitives
are used to build working programs - idioms such as basic data
structures, protocols for returning results, higher-order programming,
selective communication, and concurrent objects. The type system
integrates a number of features found in recent work on theoretical
foundations for typed object-oriented languages: higher-order
polymorphism, simple recursive types, subtyping, and a powerful
partial type inference algorithm.
2009-10-28 06:13:40 +00:00

17 lines
514 B
Text

$NetBSD: patch-af,v 1.1.1.1 2009/10/28 06:13:40 dholland Exp $
DESTDIR support.
--- Tools/Makefile~ 1998-03-22 18:27:46.000000000 -0500
+++ Tools/Makefile 2009-10-23 23:36:58.000000000 -0400
@@ -3,8 +3,8 @@ TARGETS = src2tex src2pi
include ../SiteSpecific
install:: all
- cp -f src2tex src2pi $(INSTALLLIB)
- chmod 755 $(INSTALLLIB)/src2tex $(INSTALLLIB)/src2pi
+ cp -f src2tex src2pi $(DESTDIR)$(INSTALLLIB)
+ chmod 755 $(DESTDIR)$(INSTALLLIB)/src2tex $(DESTDIR)$(INSTALLLIB)/src2pi
tags::
etags *.mll