pkgsrc/math/octave-current/patches/patch-ao
seb 66111c6d15 Introduce new framework for handling info files generation and installation.
Summary of changes:
- removal of USE_GTEXINFO
- addition of mk/texinfo.mk
- inclusion of this file in package Makefiles requiring it
- `install-info' substituted by `${INSTALL_INFO}' in PLISTs
- tuning of mk/bsd.pkg.mk:
    removal of USE_GTEXINFO
    INSTALL_INFO added to PLIST_SUBST
    `${INSTALL_INFO}' replace `install-info' in target rules
    print-PLIST target now generate `${INSTALL_INFO}' instead of `install-info'
- a couple of new patch files added for a handful of packages
- setting of the TEXINFO_OVERRIDE "switch" in packages Makefiles requiring it
- devel/cssc marked requiring texinfo 4.0
- a couple of packages Makefiles were tuned with respect of INFO_FILES and
  makeinfo command usage

See -newly added by this commit- section 10.24 of Packages.txt for
further information.
2002-02-18 15:14:00 +00:00

30 lines
912 B
Text

$NetBSD: patch-ao,v 1.1 2002/02/18 15:14:32 seb Exp $
--- doc/interpreter/Makefile.in.orig Sun Feb 17 16:26:40 2002
+++ doc/interpreter/Makefile.in
@@ -81,7 +81,7 @@
@mv $@.t $@
octave.info: $(MAIN_TEXINFO) $(SUB_TEXINFO) ../conf.texi
- -makeinfo -I$(srcdir) -I$(srcdir)/.. $<
+ -$(MAKEINFO) -I$(srcdir) -I$(srcdir)/.. $<
octave.dvi: $(MAIN_TEXINFO) $(SUB_TEXINFO) ../conf.texi
-TEXINPUTS="$(srcdir):$(srcdir)/..:$(TEXINPUTS):"; \
@@ -93,14 +93,14 @@
../../INSTALL.OCTAVE: install.texi
rm -f INSTALL
- -makeinfo -D INSTALLONLY \
+ -$(MAKEINFO) -D INSTALLONLY \
--no-validate --no-headers --no-split --output INSTALL \
-I$(srcdir) -I$(srcdir)/.. $<
mv INSTALL ../../INSTALL.OCTAVE
../../BUGS: bugs.texi
rm -f BUGS
- -makeinfo -D BUGSONLY \
+ -$(MAKEINFO) -D BUGSONLY \
--no-validate --no-headers --no-split --output BUGS \
-I$(srcdir) -I$(srcdir)/.. $<
mv BUGS ../../BUGS