1c7cc80bfe
* install pinger program setuid to make ICMP work; the problem noted by Heron Gallegos via private mail. Key changes squid-2.6.STABLE4 to 2.6.STABLE5 * Bug #1776: 2.6.STABLE4 aufs fails to compile if coss isn't enabled * COSS improvements and cleanups * Bug #1785: Memory leak in handling of negatively cached objects * Bug #1780: Incorrect Vary processing in combination with collapsed_forwarding * Bug #1779: Delay pools fairness when multiple connections compete for bandwidth * Bug #1796: Assertion error HttpHeader.c:914: "str" * All comm loops now use the generic event framework * a number of other minor and cosmetic bugfixes. See the list of squid-2.6.STABLE4 changes and the ChangeLog file for details.
41 lines
1.2 KiB
Text
41 lines
1.2 KiB
Text
$NetBSD: patch-an,v 1.12 2006/11/09 15:16:21 taca Exp $
|
|
|
|
--- configure.in.orig 2006-11-03 22:20:14.000000000 +0900
|
|
+++ configure.in
|
|
@@ -1591,6 +1591,7 @@ AC_CHECK_HEADERS(
|
|
linux/netfilter_ipv4.h \
|
|
linux/netfilter_ipv4/ip_tproxy.h \
|
|
malloc.h \
|
|
+ machine/byte_swap.h \
|
|
math.h \
|
|
memory.h \
|
|
mount.h \
|
|
@@ -1955,7 +1956,16 @@ AC_CHECK_SYSTYPE(size_t, unsigned int)
|
|
AC_CHECK_SYSTYPE(ssize_t, int)
|
|
AC_CHECK_SYSTYPE(off_t, int)
|
|
AC_CHECK_SYSTYPE(mode_t, unsigned short)
|
|
-AC_CHECK_SYSTYPE(fd_mask, int)
|
|
+
|
|
+dnl Check for type fd_mask
|
|
+AC_CACHE_CHECK(for fd_set,ac_cv_have_fd_mask, [
|
|
+ AC_TRY_COMPILE([#include <sys/types.h>
|
|
+#include <sys/time.h>
|
|
+#include <sys/unistd.h>],
|
|
+ [fd_mask fds;],
|
|
+ ac_cv_have_fd_mask="yes",
|
|
+ ac_cv_have_fd_mask="no")
|
|
+])
|
|
|
|
AC_CHECK_SIZEOF_SYSTYPE(off_t, 4)
|
|
AC_CHECK_SIZEOF_SYSTYPE(size_t, 4)
|
|
@@ -2234,8 +2244,8 @@ if test "$GCC" = "yes"; then
|
|
GCCVER=`$CC -v 2>&1 | awk '$2 == "version" {print $3}'`
|
|
case "$GCCVER" in
|
|
[2.95.[123]])
|
|
- echo "Removing -O for gcc on $host with GCC $GCCVER"
|
|
- CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*//'`"
|
|
+ echo "Making -O\[[2-9\]] to -O for gcc on $host with GCC $GCCVER"
|
|
+ CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*/-O/'`"
|
|
;;
|
|
esac
|
|
fi
|