pkgsrc/news/leafnode/patches/patch-aa
kim 387e54a560 Upgrade to 1.11.2:
* Fix segfault when timeout or connection reset encountered while
  article header is read.

* fetchnews will no longer re-fetch the active file for a server if it
  has been completely received even if fetching articles from this server
  encounters a problem.  Long-standing bug.  Debian bug #70052.

* fetchnews will now properly mark the active for complete re-fetch if
  it says so. Previously, it forgot the mark in some circumstances.  A
  problem fetching the active file or descriptions for a newly added
  server will now mark the active for re-fetch even if articles have
  successfully been retrieved from the same server.

* Fix use-after-free segfault when server dies while body is being
  received.

* Support quoted strings on the right hand side of configuration lines.

* Support IPv6 in fetchnews as well.

* In LIST ACTIVE/GROUP, keep group interesting in spite of being
  pseudo (which includes empty) as long as it is interesting. Avoids
  unsubscription of low-traffic groups that fall empty.
2005-05-13 15:08:04 +00:00

56 lines
2.2 KiB
Text

$NetBSD: patch-aa,v 1.6 2005/05/13 15:08:04 kim Exp $
--- Makefile.in.orig 2005-05-04 10:36:22.000000000 -0400
+++ Makefile.in 2005-05-13 10:53:41.000000000 -0400
@@ -801,14 +801,14 @@
rm -f "$(DESTDIR)$(man8dir)/$$inst"; \
done
install-sysconfDATA: $(sysconf_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
- @list='$(sysconf_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f=$(am__strip_dir) \
- echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
- $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
- done
+# @$(NORMAL_INSTALL)
+# test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
+# @list='$(sysconf_DATA)'; for p in $$list; do \
+# if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+# f=$(am__strip_dir) \
+# echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+# $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
+# done
uninstall-sysconfDATA:
@$(NORMAL_UNINSTALL)
@@ -1349,17 +1349,17 @@
rpmbuild -ba leafnode.spec || rpm -ba leafnode.spec
install-data-hook: amiroot
- set -e ; for i in . leaf.node failed.postings interesting.groups \
- out.going message.id temp.files ; do \
- mkdir -p $(DESTDIR)$(SPOOLDIR)/$$i ; \
- if ./amiroot ; then \
- chown @NEWS_USER@:@NEWS_GROUP@ $(DESTDIR)$(SPOOLDIR)/$$i ; \
- chmod 2775 $(DESTDIR)$(SPOOLDIR)/$$i ; fi ; \
- done
- d="`dirname $(DESTDIR)@LOCKFILE@`" ; mkdir -p "$${d}" && \
- if ./amiroot ; then \
- chown @NEWS_USER@:@NEWS_GROUP@ "$${d}" ; \
- chmod 2775 "$${d}" ; fi
+# set -e ; for i in . leaf.node failed.postings interesting.groups \
+# out.going message.id temp.files ; do \
+# mkdir -p $(DESTDIR)$(SPOOLDIR)/$$i ; \
+# if ./amiroot ; then \
+# chown @NEWS_USER@:@NEWS_GROUP@ $(DESTDIR)$(SPOOLDIR)/$$i ; \
+# chmod 2775 $(DESTDIR)$(SPOOLDIR)/$$i ; fi ; \
+# done
+# d="`dirname $(DESTDIR)@LOCKFILE@`" ; mkdir -p "$${d}" && \
+# if ./amiroot ; then \
+# chown @NEWS_USER@:@NEWS_GROUP@ "$${d}" ; \
+# chmod 2775 "$${d}" ; fi
uninstall-local:
rm -rf $(DESTDIR)$(SPOOLDIR) $(DESTDIR)@LOCKFILE@