64 lines
2.4 KiB
Text
64 lines
2.4 KiB
Text
$NetBSD: patch-ac,v 1.4 2016/01/29 15:46:48 joerg Exp $
|
|
|
|
--- lib-src/Makefile.in.in.orig 2005-11-22 07:14:42.000000000 +0000
|
|
+++ lib-src/Makefile.in.in
|
|
@@ -67,7 +67,7 @@ sitemoduledir=@sitemoduledir@
|
|
INSTALL = @install_pp@ @INSTALL@
|
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
|
INSTALL_DATA = @INSTALL_DATA@
|
|
-
|
|
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
|
## ========================== Lists of Files ===========================
|
|
|
|
#define NO_SHORTNAMES
|
|
@@ -242,7 +242,7 @@ do-blessmail: $(blessmail)
|
|
|
|
## Install the internal utilities. Until they are installed, we can
|
|
## just run them directly from lib-src.
|
|
-${archlibdir}: all
|
|
+install-archlibdir: all
|
|
@echo; echo "Installing utilities run internally by XEmacs."
|
|
./make-path ${archlibdir}
|
|
if test "`(cd ${archlibdir} && $(pwd))`" != "`$(pwd)`"; then \
|
|
@@ -253,17 +253,27 @@ ${archlibdir}: all
|
|
if test "`(cd ${archlibdir} && $(pwd))`" \
|
|
!= "`(cd ${srcdir} && $(pwd))`"; then \
|
|
for f in ${PRIVATE_INSTALLABLE_SCRIPTS}; do \
|
|
- (cd .. && $(INSTALL_PROGRAM) ${srcdir}/$$f ${archlibdir}/$$f); \
|
|
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$$f ${archlibdir}/$$f); \
|
|
done ; \
|
|
fi
|
|
|
|
-install: ${archlibdir}
|
|
+install: install-archlibdir
|
|
@echo; echo "Installing utilities for users to run."
|
|
for file in ${PUBLIC_INSTALLABLE_EXES} ; do \
|
|
- (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
|
|
- done
|
|
+ if [ $${file} = etags ] || [ $${file} = ctags ] || [ $${file} = b2m ] ; \
|
|
+ then \
|
|
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/xemacs-$${file}) ; \
|
|
+ else \
|
|
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
|
|
+ fi \
|
|
+ done
|
|
for file in ${PUBLIC_INSTALLABLE_SCRIPTS} ; do \
|
|
- (cd .. && $(INSTALL_PROGRAM) ${srcdir}/$${file} ${bindir}/$${file}) ; \
|
|
+ if [ $${file} = rcs-checkin ] || [ $${file} = send-pr ] ; \
|
|
+ then \
|
|
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/xemacs-$${file}) ; \
|
|
+ else \
|
|
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file}) ; \
|
|
+ fi \
|
|
done
|
|
|
|
uninstall:
|
|
@@ -387,7 +397,7 @@ make-po: ${srcdir}/make-po.c
|
|
make-dump-id: ${srcdir}/make-dump-id.c
|
|
$(CC) $(cflags) ${srcdir}/make-dump-id.c $(ldflags) -o $@
|
|
|
|
-#ifndef DUMP_IN_EXEC
|
|
+#ifdef DUMP_IN_EXEC
|
|
insert-data-in-exec: ${srcdir}/insert-data-in-exec.c
|
|
$(CC) $(cflags) ${srcdir}/insert-data-in-exec.c $(ldflags) -o $@
|
|
#endif /* not DUMP_IN_EXEC */
|