pkgsrc/sysutils/grub2/patches/patch-stpcpy-1.diff
gsutre d4ff70ea49 Import grub2-2.00 as sysutils/grub2.
This is GRUB 2, the second version of the GRand Unified Bootloader.
GRUB 2 is rewritten from scratch to make GNU GRUB cleaner, safer, more
robust, more powerful, and more portable.
2012-07-29 21:44:13 +00:00

176 lines
5.4 KiB
Diff

$NetBSD: patch-stpcpy-1.diff,v 1.1 2012/07/29 21:44:13 gsutre Exp $
Add gnulib's stpcpy.
=== modified file 'grub-core/gnulib/Makefile.am'
--- grub-core/gnulib/Makefile.am 2010-09-20 23:09:23 +0000
+++ grub-core/gnulib/Makefile.am 2012-07-28 13:09:43 +0000
@@ -9,7 +9,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex stpcpy
AUTOMAKE_OPTIONS = 1.5 gnits
@@ -859,6 +859,15 @@
## end gnulib module stdlib
+## begin gnulib module stpcpy
+
+
+EXTRA_DIST += stpcpy.c
+
+EXTRA_libgnu_a_SOURCES += stpcpy.c
+
+## end gnulib module stpcpy
+
## begin gnulib module strcase
=== added file 'grub-core/gnulib/stpcpy.c'
--- grub-core/gnulib/stpcpy.c 1970-01-01 00:00:00 +0000
+++ grub-core/gnulib/stpcpy.c 2012-07-28 13:09:38 +0000
@@ -0,0 +1,49 @@
+/* stpcpy.c -- copy a string and return pointer to end of new string
+ Copyright (C) 1992, 1995, 1997-1998, 2006, 2009-2010 Free Software
+ Foundation, Inc.
+
+ NOTE: The canonical source of this file is maintained with the GNU C Library.
+ Bugs can be reported to bug-glibc@prep.ai.mit.edu.
+
+ This program is free software: you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by the
+ Free Software Foundation; either version 3 of the License, or any
+ later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+
+#include <config.h>
+
+#include <string.h>
+
+#undef __stpcpy
+#ifdef _LIBC
+# undef stpcpy
+#endif
+
+#ifndef weak_alias
+# define __stpcpy stpcpy
+#endif
+
+/* Copy SRC to DEST, returning the address of the terminating '\0' in DEST. */
+char *
+__stpcpy (char *dest, const char *src)
+{
+ register char *d = dest;
+ register const char *s = src;
+
+ do
+ *d++ = *s;
+ while (*s++ != '\0');
+
+ return d - 1;
+}
+#ifdef weak_alias
+weak_alias (__stpcpy, stpcpy)
+#endif
=== modified file 'm4/gnulib-cache.m4'
--- m4/gnulib-cache.m4 2010-09-20 23:09:23 +0000
+++ m4/gnulib-cache.m4 2012-07-28 13:09:43 +0000
@@ -15,7 +15,7 @@
# Specification in the form of a command-line invocation:
-# gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex
+# gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex stpcpy
# Specification in the form of a few gnulib-tool.m4 macro invocations:
gl_LOCAL_DIR([])
@@ -28,6 +28,7 @@
gettext
progname
regex
+ stpcpy
])
gl_AVOID([])
gl_SOURCE_BASE([grub-core/gnulib])
=== modified file 'm4/gnulib-comp.m4'
--- m4/gnulib-comp.m4 2010-09-20 23:09:23 +0000
+++ m4/gnulib-comp.m4 2012-07-28 13:09:44 +0000
@@ -73,6 +73,7 @@
# Code from module stdint:
# Code from module stdio:
# Code from module stdlib:
+ # Code from module stpcpy:
# Code from module strcase:
# Code from module strchrnul:
# Code from module streq:
@@ -221,6 +222,9 @@
gl_STDIO_H
# Code from module stdlib:
gl_STDLIB_H
+ # Code from module stpcpy:
+ gl_FUNC_STPCPY
+ gl_STRING_MODULE_INDICATOR([stpcpy])
# Code from module strcase:
gl_STRCASE
# Code from module strchrnul:
@@ -482,6 +486,7 @@
lib/stdio-write.c
lib/stdio.in.h
lib/stdlib.in.h
+ lib/stpcpy.c
lib/strcasecmp.c
lib/strchrnul.c
lib/strchrnul.valgrind
@@ -576,6 +581,7 @@
m4/stdint_h.m4
m4/stdio_h.m4
m4/stdlib_h.m4
+ m4/stpcpy.m4
m4/strcase.m4
m4/strchrnul.m4
m4/strerror.m4
=== added file 'm4/stpcpy.m4'
--- m4/stpcpy.m4 1970-01-01 00:00:00 +0000
+++ m4/stpcpy.m4 2012-07-28 13:09:38 +0000
@@ -0,0 +1,26 @@
+# stpcpy.m4 serial 7
+dnl Copyright (C) 2002, 2007, 2009, 2010 Free Software Foundation, Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+
+AC_DEFUN([gl_FUNC_STPCPY],
+[
+ dnl Persuade glibc <string.h> to declare stpcpy().
+ AC_REQUIRE([AC_USE_SYSTEM_EXTENSIONS])
+
+ dnl The stpcpy() declaration in lib/string.in.h uses 'restrict'.
+ AC_REQUIRE([AC_C_RESTRICT])
+
+ AC_REQUIRE([gl_HEADER_STRING_H_DEFAULTS])
+ AC_REPLACE_FUNCS([stpcpy])
+ if test $ac_cv_func_stpcpy = no; then
+ HAVE_STPCPY=0
+ gl_PREREQ_STPCPY
+ fi
+])
+
+# Prerequisites of lib/stpcpy.c.
+AC_DEFUN([gl_PREREQ_STPCPY], [
+ :
+])