520d354235
The GNU Compiler Collection (GCC) includes front ends for C, C++, Objective-C, Fortran, Java, and Go, as well as libraries for these languages (libstdc++, libgcj,...). This package provides the snapshot release of version 5. On NetBSD a working cabsl function must be present in libm to build gfortran. This has been added to -current on 2014/10/10 and to NetBSD7 on 2014/10/13.
17 lines
1.5 KiB
Text
17 lines
1.5 KiB
Text
$NetBSD: patch-libgo_Makefile.in,v 1.1 2015/07/16 12:03:36 ryoon Exp $
|
|
|
|
proc.c will not compile with inline-functions (implied by -O3)
|
|
so add -fno-inline-functions to it's cflags.
|
|
|
|
|
|
--- libgo/Makefile.in.orig 2012-08-06 14:34:27.000000000 +0000
|
|
+++ libgo/Makefile.in
|
|
@@ -3051,7 +3051,7 @@ print.lo: runtime/print.c
|
|
@am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o print.lo `test -f 'runtime/print.c' || echo '$(srcdir)/'`runtime/print.c
|
|
|
|
proc.lo: runtime/proc.c
|
|
-@am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT proc.lo -MD -MP -MF $(DEPDIR)/proc.Tpo -c -o proc.lo `test -f 'runtime/proc.c' || echo '$(srcdir)/'`runtime/proc.c
|
|
+@am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) -fno-inline-functions $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT proc.lo -MD -MP -MF $(DEPDIR)/proc.Tpo -c -o proc.lo `test -f 'runtime/proc.c' || echo '$(srcdir)/'`runtime/proc.c
|
|
@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/proc.Tpo $(DEPDIR)/proc.Plo
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='runtime/proc.c' object='proc.lo' libtool=yes @AMDEPBACKSLASH@
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|