pkgsrc/filesystems/fuse/patches/patch-an
manu db9a921ee0 Update FUSE to 2.8.4 and add NetBSD support through filesystems/perfuse
Changes since previous verion, from the NEWS file

2.8.x:
- More scalable directory tree locking
- Atomic open(O_TRUNC) support
- Support big write requests on kernels 2.6.26 and newer
- Out-of-tree fuse module removed
- Better NFS exporting support
- New ioctl and poll requests
- New CUSE (Character Device in Userspace) interface
- Allow umask processing in userspace
- Added cache invalidation notifications
- Bugfixes and small improvements
2.7.x:
 - Stacking support for the high level API
 - Add filename charset conversion module
 - Improved mounting
2.6.x!
 - Improved read characteristics (asynchronous reads)
 - Support for aborting filesystem connection
 - POSIX file locking support
 - Request interruption support
 - Building module for Linux kernels earlier than 2.6.9 not supported
 - Allow block device based filesystems to support swap files
 - Several bugs fixed, including a rare system hang on SMP
2010-08-25 08:02:21 +00:00

16 lines
535 B
Text

$NetBSD: patch-an,v 1.1 2010/08/25 08:02:21 manu Exp $
Link with -lperfuse on NetBSD
--- lib/Makefile.in.orig 2010-08-24 09:33:40.000000000 +0200
+++ lib/Makefile.in 2010-08-24 09:35:20.000000000 +0200
@@ -263,8 +263,10 @@
libfuse_la_LDFLAGS = @libfuse_libs@ -version-number 2:8:4 \
-Wl,--version-script,$(srcdir)/fuse_versionscript
+@NETBSD_TRUE@libfuse_la_LIBADD = -lperfuse -lpuffs
+
libulockmgr_la_SOURCES = ulockmgr.c
libulockmgr_la_LDFLAGS = -pthread -version-number 1:0:1
EXTRA_DIST = fuse_versionscript
all: all-am