and friends, as well as Newton, Barnsley, Phoenix, and Magnet), that can also be used as an external module in xscreensaver.
44 lines
967 B
Text
44 lines
967 B
Text
$NetBSD: patch-aa,v 1.1 2002/03/25 16:19:31 atatat Exp $
|
|
|
|
Rip out the 16 bit i387 specific code.
|
|
|
|
--- src/engine/fractal.c-orig Wed Mar 4 16:49:12 1998
|
|
+++ src/engine/fractal.c Sun Mar 10 16:29:06 2002
|
|
@@ -48,13 +48,6 @@
|
|
#include <complex.h>
|
|
#include <plane.h>
|
|
#include <timers.h>
|
|
-#ifdef __GNUC__
|
|
-#ifdef __i386__
|
|
-#ifndef PC_64
|
|
-#include <i386/ctrl87.h>
|
|
-#endif
|
|
-#endif
|
|
-#endif
|
|
#ifdef __alpha__
|
|
#ifdef __linux__
|
|
#include <asm/fpu.h>
|
|
@@ -333,11 +326,6 @@
|
|
{
|
|
fractal_context *new_ctxt;
|
|
|
|
-#ifdef __GNUC__
|
|
-#ifdef __i386__
|
|
- _control87 (PC_64 | MCW_EM | MCW_RC, MCW_PC | MCW_EM | MCW_RC);
|
|
-#endif
|
|
-#endif
|
|
#ifdef __alpha__
|
|
#ifdef __linux__
|
|
extern void ieee_set_fp_control(unsigned long);
|
|
--- src/engine/Makefile.in-orig Wed Mar 4 16:49:12 1998
|
|
+++ src/engine/Makefile.in Sun Mar 10 16:27:30 2002
|
|
@@ -22,8 +22,7 @@
|
|
stereogram.c \
|
|
subwindow.c \
|
|
plane.c \
|
|
- julia.c \
|
|
- i386.c
|
|
+ julia.c
|
|
|
|
OBJS = $(SRCS:.c=.o)
|
|
|