34 lines
1.1 KiB
Text
34 lines
1.1 KiB
Text
$NetBSD: patch-aa,v 1.6 2004/12/06 16:20:12 minskim Exp $
|
|
|
|
--- configure.in.orig 2004-09-30 23:24:09.000000000 -0500
|
|
+++ configure.in
|
|
@@ -469,6 +469,7 @@ fi
|
|
if test "x$xc_with_tcl" != "x" ; then
|
|
. $tcl_config_sh
|
|
. $tk_config_sh
|
|
+ LIBS="${LIBS} ${TCL_LIBS}"
|
|
|
|
if test "$TCL_VERSION" = "7.6" -a "$TK_VERSION" = "4.2" ; then
|
|
:
|
|
@@ -544,7 +545,7 @@ fi
|
|
|
|
if test "x$xc_with_tcl" != "x" ; then
|
|
case $target in
|
|
- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
|
+ *-sunos4*|*-*-netbsd|*-*-netbsdelf|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
|
TCL_LIB_NAME="tcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}"
|
|
TK_LIB_NAME="tk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}"
|
|
;;
|
|
@@ -890,9 +891,9 @@ if test "x$xc_with_tcl" != "x" ; then
|
|
# Not available on all versions: check for include file.
|
|
AC_CHECK_HEADER(dlfcn.h, test_ok=yes, test_ok=no)
|
|
if test "$test_ok" = yes; then
|
|
- SHLIB_CFLAGS="-fpic"
|
|
- SHLIB_LD="ld"
|
|
- LDDL_FLAGS="-Bshareable -x ${LIB_SPEC}"
|
|
+ SHLIB_CFLAGS="-fPIC"
|
|
+ SHLIB_LD=$CC
|
|
+ LDDL_FLAGS="-shared"
|
|
fi
|
|
;;
|
|
|