pkgsrc/devel/nspr/patches/patch-ba
ryoon 3fd37557f7 Update to 4.10, based on pkgsrc/wip/nspr by mef@.
* Set LICENSE.

Changelog:
http://mozilla.6506.n7.nabble.com/ANNOUNCE-NSPR-4-10-Release-td280660.html
--------------
  NSPR 4.10 has the following bug fixes:
* Bug 331169: Obviate PR_Sleep before PR_GetConnectStatus on Windows.
  Fixed by Brian Smith.
* Bug 687033: Support Windows/arm. Fixed by Makoto Kato (partially
  checked in).
* Bug 687033: Remove WINCE and Win9x support partially.
* Bug 844513: Add AddressSanitizer (ASan) memory check annotations to
  PLArena. Fixed by Mats Palmgren.
* Bug 849089: Simple changes to make NSPR's configure.in work with
  the current version of autoconf.
* Bug 856196: Fix compiler warnings and clean up code in NSPR 4.10.
* Bug 859066: Fix warning in nsprpub/pr/src/misc/prnetdb.c.
* Bug 859830: Deprecate ANDROID_VERSION in favor of android/api-level.h.
  Fixed by Vicamo Yang.
* Bug 861434: Make PR_SetThreadPriority() change priorities
  relatively to the main process instead of using absolute values on
  Linux. Fixed by Gabriele Svelto.
* Bug 871064L: _PR_InitThreads() should not call PR_SetThreadPriority.
2013-07-20 08:57:20 +00:00

24 lines
752 B
Text

$NetBSD: patch-ba,v 1.2 2013/07/20 08:57:20 ryoon Exp $
pthread_t may be 64-bit, avoid casting it.
--- nsprpub/pr/include/private/pprthred.h.orig 2009-11-02 22:43:08.000000000 +0100
+++ nspr/pr/include/private/pprthred.h
@@ -51,6 +51,8 @@
#include <os2.h>
#endif
+#include <pthread.h>
+
PR_BEGIN_EXTERN_C
/*---------------------------------------------------------------------------
@@ -91,7 +93,7 @@ NSPR_API(void) PR_DetachThread(void);
** Get the id of the named thread. Each thread is assigned a unique id
** when it is created or attached.
*/
-NSPR_API(PRUint32) PR_GetThreadID(PRThread *thread);
+NSPR_API(pthread_t) PR_GetThreadID(PRThread *thread);
/*
** Set the procedure that is called when a thread is dumped. The procedure