9470cde812
Main changes since 3.4.0: --disable-non-free configure option Changed default language dialect from --std-sdcc89 to --std-sdcc99 Reorganized and updated manual Reduced memory consumption (most noticeable for high --max-allocs-per-node) Faster compilation for stm8 (most noticeable for high --max-allocs-per-node) atoll() function for conversion of strings to long long __z88dk_fastcall and __z88dk_callee calling conventions for more efficient function calls and better compability with z88dk --lospre-unsafe-read renamed to --allow-unsafe-read Add new microchip devices
34 lines
1.2 KiB
Text
34 lines
1.2 KiB
Text
$NetBSD: patch-device_non-free_lib_Makefile.in,v 1.2 2015/08/22 17:06:16 bouyer Exp $
|
|
|
|
--- device/non-free/lib/Makefile.in.orig 2015-03-26 14:21:24.000000000 +0100
|
|
+++ device/non-free/lib/Makefile.in 2015-08-22 13:09:20.000000000 +0200
|
|
@@ -353,17 +353,6 @@
|
|
install: all installdirs
|
|
ifneq ($(TARGETS), )
|
|
[ ! -d "$(BUILDDIR)" ] || $(CP_U) -r $(BUILDDIR)/* $(sdcc_libdir)
|
|
- $(CP_U) -r $(foreach p, $(ENABLED_PORTS), $(srcdir)/$(p)) $(sdcc_libdir)/src
|
|
-
|
|
- for src in $(ENABLED_PORTS); do \
|
|
- find $(sdcc_libdir)/src/$$src -depth \
|
|
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
|
|
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'autom4te.cache' -o \
|
|
- -name 'build' -o -name 'bin' -o -name 'Makefile*' -o -name 'config*' -o \
|
|
- -name 'depcomp' -o -name 'missing' -o -name 'install-sh' -o \
|
|
- -name 'bootstrap.sh' \) \
|
|
- -exec rm -rf {} + ; \
|
|
- done
|
|
endif
|
|
|
|
# Deleting all the installed files
|
|
@@ -385,10 +374,7 @@
|
|
# ---------------------------------
|
|
installdirs:
|
|
ifneq ($(TARGETS), )
|
|
- for libdir in $(ENABLED_PORTS); do \
|
|
- mkdir -p $(sdcc_libdir)/$$libdir; \
|
|
- done
|
|
- mkdir -p $(sdcc_libdir)/src
|
|
+ mkdir -p $(sdcc_libdir)
|
|
endif
|
|
|
|
# Creating dependencies
|