pkgsrc/devel/st/patches/patch-ab
gson 65276b8c27 Update devel/st all the way from 1.5.1 to 1.8.
Changes from 1.7 to 1.8.
--------------------------
o  Added support for kqueue and epoll on platforms that support them.
   Added ability to choose the event notification system at program
   startup.

o  Long-overdue public definitions of ST_UTIME_NO_TIMEOUT (-1ULL) and
   ST_UTIME_NO_WAIT (0) [bug 1514436].

o  Documentation patch for st_utime() [bug 1514484].

o  Documentation patch for st_timecache_set() [bug 1514486].

o  Documentation patch for st_netfd_serialize_accept() [bug 1514494].

o  Added st_writev_resid() [rfe 1538344].

o  Added st_readv_resid() [rfe 1538768] and, for symmetry, st_readv().


Changes from 1.6 to 1.7.
------------------------
o  Support glibc 2.4, which breaks programs that manipulate jump buffers.
   Replaced Linux IA64 special cases with new md.S that covers all
   Linux.


Changes from 1.5.2 to 1.6.
--------------------------
none


Changes from 1.5.1 to 1.5.2.
----------------------------
o  Alfred Perlstein's context switch callback feature.

o  Claus Assmann's st_recvmsg/st_sendmsg wrappers.

o  Extra stack padding for platforms that need it.

o  Ron Arts's timeout clarifications in the reference manual.

o  Raymond Bero and Anton Berezin's AMD64 FreeBSD port.

o  Claus Assmann's AMD64 SunOS 5.10 port.

o  Claus Assmann's AMD64 OpenBSD port.

o  Michael Abd-El-Malek's Mac OS X port.

o  Michael Abd-El-Malek's stack printing patch.
2009-03-10 11:13:09 +00:00

52 lines
1.7 KiB
Text

$NetBSD: patch-ab,v 1.3 2009/03/10 11:13:09 gson Exp $
--- examples/Makefile.orig 2004-01-11 02:15:17.000000000 +0200
+++ examples/Makefile
@@ -60,9 +60,9 @@ CFLAGS =
OTHER_FLAGS =
OBJDIR = $(DEPTH)/$(TARGETDIR)
-INCDIR = $(DEPTH)/$(TARGETDIR)
-LIBST = $(OBJDIR)/libst.a
-HEADER = $(INCDIR)/st.h
+INCDIR = $(DEPTH)
+LIBST = $(DEPTH)/libst.la
+HEADER = $(DEPTH)/st.h
LIBRESOLV =
EXTRALIBS =
@@ -70,7 +70,7 @@ EXTRALIBS =
ifeq ($(OS),)
EXAMPLES = unknown
else
-EXAMPLES = $(OBJDIR)/lookupdns $(OBJDIR)/proxy $(OBJDIR)/server
+EXAMPLES = lookupdns proxy server
endif
@@ -94,17 +94,17 @@ endif
all: $(EXAMPLES)
-$(OBJDIR)/lookupdns: lookupdns.c $(OBJDIR)/res.o $(LIBST) $(HEADER)
- $(CC) $(CFLAGS) -I$(INCDIR) lookupdns.c $(OBJDIR)/res.o $(LIBST) $(LIBRESOLV) $(EXTRALIBS) -o $@
+lookupdns: lookupdns.lo res.lo $(LIBST) $(HEADER)
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I$(INCDIR) lookupdns.lo res.lo $(LIBST) $(LIBRESOLV) $(EXTRALIBS) -o $@
-$(OBJDIR)/proxy: proxy.c $(LIBST) $(HEADER)
- $(CC) $(CFLAGS) -I$(INCDIR) proxy.c $(LIBST) $(EXTRALIBS) -o $@
+proxy: proxy.lo $(LIBST) $(HEADER)
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I$(INCDIR) proxy.lo $(LIBST) $(EXTRALIBS) -o $@
-$(OBJDIR)/server: server.c $(OBJDIR)/error.o $(LIBST) $(HEADER)
- $(CC) $(CFLAGS) -I$(INCDIR) server.c $(OBJDIR)/error.o $(LIBST) $(EXTRALIBS) -o $@
+server: server.lo error.lo $(LIBST) $(HEADER)
+ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I$(INCDIR) server.lo error.lo $(LIBST) $(EXTRALIBS) -o $@
-$(OBJDIR)/%.o: %.c
- $(CC) $(CFLAGS) -I$(INCDIR) -c $< -o $@
+%.lo: %.c
+ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -I$(INCDIR) -c $< -o $@
.DEFAULT:
@cd $(DEPTH); $(MAKE) $@