This release adds many new features which enhance PostgreSQL's flexibility, scalability and performance for many different types of database users, including improvements to JSON support, replication and index performance.
24 lines
871 B
Text
24 lines
871 B
Text
$NetBSD: patch-src_backend_Makefile,v 1.1 2015/01/14 21:01:18 adam Exp $
|
|
|
|
--- src/backend/Makefile.orig 2014-12-16 01:07:34.000000000 +0000
|
|
+++ src/backend/Makefile
|
|
@@ -17,6 +17,10 @@ subdir = src/backend
|
|
top_builddir = ../..
|
|
include $(top_builddir)/src/Makefile.global
|
|
|
|
+CFLAGS+= $(DL_CFLAGS)
|
|
+LDFLAGS+= $(DL_LDFLAGS)
|
|
+LIBS+= $(DL_LIBS)
|
|
+
|
|
SUBDIRS = access bootstrap catalog parser commands executor foreign lib libpq \
|
|
main nodes optimizer port postmaster regex replication rewrite \
|
|
storage tcop tsearch utils $(top_builddir)/src/timezone
|
|
@@ -121,6 +125,8 @@ catalog/schemapg.h: | submake-schemapg
|
|
|
|
$(top_builddir)/src/port/libpgport_srv.a: | submake-libpgport
|
|
|
|
+$(top_builddir)/src/common/libpgcommon_srv.a: | submake-libpgport
|
|
+
|
|
|
|
# The postgres.o target is needed by the rule in Makefile.global that
|
|
# creates the exports file when MAKE_EXPORTS = true.
|