pkgsrc/mail/postfix/patches/patch-aa
jmmv 83877c7a60 - Move all "share" files to share/examples/postfix; all of them are used
as samples, either by the user or by bsd.pkg.install.mk.
- Correctly handle configuration files, that is, avoid touching the conf
  directory directly.
- Use OWN_DIRS to handle the spool directory.
- Run post-install through an INSTALL script.
- Sort PLIST after all these changes.
- Bump PKGREVISION to 1.
2003-05-01 14:07:56 +00:00

53 lines
1.6 KiB
Text

$NetBSD: patch-aa,v 1.13 2003/05/01 14:07:58 jmmv Exp $
--- postfix-install.orig 2003-03-21 20:04:53.000000000 +0100
+++ postfix-install
@@ -338,33 +338,13 @@ README files. Specify \"no\" if you do n
: ${tempdir=`pwd`}
: ${config_directory=`bin/postconf -h -d config_directory`}
-# Find out the location of installed configuration files.
-
-test -z "$non_interactive" && for name in install_root tempdir config_directory
-do
- while :
- do
- echo
- eval echo Please specify \$${name}_prompt | ${FMT}
- eval echo \$n "$name: [\$$name]\ \$c"
- read ans
- case $ans in
- "") break;;
- *) case $ans in
- /*) eval $name=$ans; break;;
- *) echo; echo $0: Error: $name should be an absolute path name. 1>&2;;
- esac;;
- esac
- done
-done
-
# In case some systems special-case pathnames beginning with //.
case $install_root in
/) install_root=
esac
-CONFIG_DIRECTORY=$install_root$config_directory
+CONFIG_DIRECTORY=conf
# If a parameter is not set via the command line or environment,
# try to use settings from installed configuration files.
@@ -652,13 +632,3 @@ bin/postconf -c $CONFIG_DIRECTORY -e \
"sample_directory = $sample_directory" \
"readme_directory = $readme_directory" \
|| exit 1
-
-# If Postfix is being installed locally from source code, do the
-# post-install processing now.
-
-test -n "$install_root" || {
- export daemon_directory command_directory queue_directory sendmail_path \
- newaliases_path mailq_path mail_owner setgid_group manpage_directory \
- sample_directory readme_directory
- ${SHELL} conf/post-install $post_install_options || exit 1
-}