pkgsrc/time/remind/patches/patch-configure.in
schmonz f1bb0acdc8 Update to 3.1.12. From the changelog:
* Version 3.1 Patch 12 - 2012-01-23

- NEW FEATURE: Many substitution sequences "%x" have an alternate mode
  denoted by "%*x".  This alternate mode leaves out prepositions.  For
  example, in English "%i" might yield "on 01-25" while "%*i" yields only
  "01-25".
- BUG FIX: The "dusk" and "dawn" calculations were completely wrong.  They
  have been fixed.  Also, sunrise/sunset calculations have been tweaked,
  so the results may be off by a minute or two compared to previous versions
  of Remind.

* Version 3.1 Patch 11 - 2011-12-16

- BUG FIX: For some inexplicable reason, dawn was considered to happen when
  the sun was 14 degrees below the horizon instead of the standard 6
  degrees for Civil Dawn.  This has been fixed.
- BUG FIXES: Clarified the man pages and fixed some typos.
- BUG FIX: Add THROUGH to the remind.vim syntax highlighting file.
- ENHANCEMENT (?): Allow SPECIAL COLOR to be spelled SPECIAL COLOUR.
- BUG FIX: Apply minor Debian cleanups reported by Kurt B. Kaiser.

* Version 3.1 Patch 10 - 2010-11-01

- NOTE: This is the 20th anniversary of Remind's first public release.
- ENHANCEMENT: Add the THROUGH keyword.  You can omit blocks of dates with:
  OMIT start THROUGH end
  and the syntax REM start THROUGH end is equivalent to REM start *1 UNTIL end
- ENHANCEMENT: Add support for multibyte characters (eg, UTF-8) in calendar
  output.  Note that UTF-8 strings are still not supported in PostScript
  output.
- ENHANCEMENT: Add support for UTF-8 line-drawing characters in calendar
  output.
- ENHANCEMENT: You can have multiple TAG clauses in a REM statement.
- BUG FIX: Avoid spawning long-running background processes in "make test".
- BUG FIX: Don't declare variables in the middle of statements (old C
  compilers choke.)

pkgsrc changes:

* Don't heap punishment on Apple and Microsoft users.
2013-02-16 13:34:59 +00:00

24 lines
596 B
Text

$NetBSD: patch-configure.in,v 1.1 2013/02/16 13:34:59 schmonz Exp $
Don't heap punishment on Apple and Microsoft users.
--- configure.in.orig 2012-01-23 18:11:13.000000000 +0000
+++ configure.in
@@ -14,7 +14,7 @@ EOF
AC_CONFIG_HEADER(src/config.h)
-if test "`uname -s`" = "Darwin" ; then
+if false && test "`uname -s`" = "Darwin" ; then
trap 'echo Be patient...' INT TERM
cat <<'EOF'
@@ -29,7 +29,7 @@ EOF
trap - TERM
fi
-if uname -s | grep -i -q 'cygwin' ; then
+if false && uname -s | grep -i -q 'cygwin' ; then
trap 'echo Be patient...' INT TERM
cat <<'EOF'