pkgsrc/x11/xproto/patches/patch-configure
wiz 12548b29dd Update to 7.0.23, based on Makoto Fujiwara's update to 7.0.23 in PR 45465.
I've reduced the patch to configure further.

7.0.23:
This release continues our documentation improvements, defines new keysyms
needed for input of various langugages, and fixes a couple compliation errors
in software that includes these headers when building either in C89 mode
(without C99 varargs macros) or in the Cygwin environment.

7.0.22:
This release provides a number of documentation improvements, a few new
macros and new keysyms.

7.0.21:
This release contains the addition of Sinhala Unicode keysysm and a
couple of compiler fixes and additions.

7.0.20:
This release provides two code changes - an additional #include <sys/types.h>
on Solaris machines to fix build issues in the X server, and the addition of
new XF86XK_TouchpadOn & XF86XK_TouchpadOff keysyms to the keysym definition
headers.

It also now includes the definitions of the ServerInterpreted families of
addresses that have been registered for use with the xhost +si:* syntax,
that were previously found in the xorg-docs module, since the X11 Protocol
spec defines the ServerInterpreted method and provides for those definitions.

The rest of the changes are further refinements of the DocBook/XML conversion
of the protocol spec which was introduced in xproto 7.0.19.   The HTML & PDF
versions should both feature greatly improved internal hyperlinking to allow
easier navigation and following of references between the interconnected
requests and events in the spec.   The conversion of the documentation is a
work in progress, and we appreciate all proof-reading to find errors (this
release fixes a couple spots where nroff markup didn't get properly converted
and appeared in the resulting text) as well as feedback on formatting or other
changes that would make the documentation more useful to developers.  Of course,
we are being very careful to not change the actual formal specification of the
protocol in these changes, just the formatting and usability.

7.0.19:
No code nor headers were changed in this release - this solely consists
of the move of the X11 Protocol specification from xorg-docs to this
module, and it's conversion from troff to DocBook XML by Matt Dew
(with some followup markup massaging by yours truly).  There is of course
still room for improvement as there are over a hundred pages to be proofread
 - patches accepted if you see ways to make the output better.

The standard xorg-macros options are provided in configure to control
the generation of text, html, postscript, and/or pdf versions of the
documents from the XML sources, via the xmlto frontend and it's associated
backends such as fop.
2012-06-03 19:57:33 +00:00

159 lines
4.7 KiB
Text

$NetBSD: patch-configure,v 1.1 2012/06/03 19:57:33 wiz Exp $
--- configure.orig 2012-03-16 06:11:49.000000000 +0000
+++ configure
@@ -1964,12 +1982,79 @@ $as_echo "$ac_res" >&6; }
eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
} # ac_fn_c_check_member
+
+# ac_fn_c_check_func LINENO FUNC VAR
+# ----------------------------------
+# Tests whether FUNC exists, setting the cache variable VAR accordingly
+ac_fn_c_check_func ()
+{
+ as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $2" >&5
+$as_echo_n "checking for $2... " >&6; }
+if eval \${$3+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+/* Define $2 to an innocuous variant, in case <limits.h> declares $2.
+ For example, HP-UX 11i <limits.h> declares gettimeofday. */
+#define $2 innocuous_$2
+
+/* System header to define __stub macros and hopefully few prototypes,
+ which can conflict with char $2 (); below.
+ Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
+ <limits.h> exists even on freestanding compilers. */
+
+#ifdef __STDC__
+# include <limits.h>
+#else
+# include <assert.h>
+#endif
+
+#undef $2
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char $2 ();
+/* The GNU C library defines this for functions which it implements
+ to always fail with ENOSYS. Some functions are actually named
+ something starting with __ and the normal name is an alias. */
+#if defined __stub_$2 || defined __stub___$2
+choke me
+#endif
+
+int
+main ()
+{
+return $2 ();
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_link "$LINENO"; then :
+ eval "$3=yes"
+else
+ eval "$3=no"
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+fi
+eval ac_res=\$$3
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
+$as_echo "$ac_res" >&6; }
+ eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
+
+} # ac_fn_c_check_func
cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
It was created by Xproto $as_me 7.0.23, which was
-generated by GNU Autoconf 2.68. Invocation command line was
+generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -11099,6 +11183,8 @@ ac_config_headers="$ac_config_headers do
ac_config_headers="$ac_config_headers Xfuncproto.h"
+ac_config_headers="$ac_config_headers Xos_r.h"
+
@@ -11350,6 +11436,56 @@ $as_echo "#define NARROWPROTO /**/" >>co
fi
+# Handle Xos_r.h
+ac_fn_c_check_func "$LINENO" "readdir_r" "ac_cv_func_readdir_r"
+if test "x$ac_cv_func_readdir_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_DIRENTAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "getgrgid_r" "ac_cv_func_getgrgid_r"
+if test "x$ac_cv_func_getgrgid_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_GRPAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "getpwuid_r" "ac_cv_func_getpwuid_r"
+if test "x$ac_cv_func_getpwuid_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_PWDAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "gethostbyname_r" "ac_cv_func_gethostbyname_r"
+if test "x$ac_cv_func_gethostbyname_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_NETDBAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "strtok_r" "ac_cv_func_strtok_r"
+if test "x$ac_cv_func_strtok_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_STRINGAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "gmtime_r" "ac_cv_func_gmtime_r"
+if test "x$ac_cv_func_gmtime_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_TIMEAPI /**/" >>confdefs.h
+
+fi
+
+ac_fn_c_check_func "$LINENO" "ttyname_r" "ac_cv_func_ttyname_r"
+if test "x$ac_cv_func_ttyname_r" = xyes; then :
+
+$as_echo "#define _XOS_R_H_MTSAFE_UNISTDAPI /**/" >>confdefs.h
+
+fi
+
ac_config_files="$ac_config_files Makefile specs/Makefile specs/SIAddresses/Makefile Xpoll.h xproto.pc"
@@ -12113,6 +12237,7 @@ do
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"do-not-use-config.h") CONFIG_HEADERS="$CONFIG_HEADERS do-not-use-config.h" ;;
"Xfuncproto.h") CONFIG_HEADERS="$CONFIG_HEADERS Xfuncproto.h" ;;
+ "Xos_r.h") CONFIG_HEADERS="$CONFIG_HEADERS Xos_r.h" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"specs/Makefile") CONFIG_FILES="$CONFIG_FILES specs/Makefile" ;;
"specs/SIAddresses/Makefile") CONFIG_FILES="$CONFIG_FILES specs/SIAddresses/Makefile" ;;