pkgsrc/x11/lablgtk/patches/patch-aa
wiz 27154c887e Update to 2.14.1, with additional patches from upstream to build with
ocaml-3.12. Set LICENSE. Add gtksourceview2 option; disable (default off)
glade option, since it currently doesn't build.

In Lablgtk-2.14.1:

2010.05.20 [Jacques]
  * update unison patch to 2.40.16 (for Quartz users)

2010.05.18 [Jacques]
  * rename gtkSignal.ml to gtkSignal.ml4 and fix depend target
  * move Glib.Utf8 code to gutf8.ml, so that it can be used in xml_lexer
    to fix a bug report by Pascal Brisset (multibyte entities of the form
    ● in glade files).

2010.04.08 [Jacques]
  * remove useless methods (discovered by ocaml 3.12)

2010.01.14 [Benjamin]
  * Apply patch from Mike Spivey to support get_visible range in Gtree
  * Fixed incorrect target labgtkspell.cmxs in Makefile

2009.10.01 [Jacques]
  * Correct wrong module name SourceViewEnums -> SourceView2Enums

In Lablgtk-2.14.0:

2009.09.25 [Jacques]
  * Ensure compilation under windows

2009.09.22 [Benjamin]
  * Restore compatibility with pre-3.11 OCaml versions

2009.09.01 [Benjamin]
  * Apply patch from Mike Spivey:
    * Access to StyleSchemeManager objects
    * Some attributes are strings and not string options.  This seems
      sensible.
    * Languages and style schemes are treated alike in creating buffers:
      both arguments are wrapped.
    * draw_spaces deals with a list of flags, not a single flag.
    * Mark categories can have priorities, icons and backgrounds
    * Some attributes of languages are accessed by methods instead of
      properties to work around a GTK bug.

2009.09.01 [Benjamin]
  * Support for GtkSourceView 2.6 in library "lablgtksourceview2"
  * Support for GtkSourceView 1.x is still available in library
    "lablgtksourceview" but it is no longer linked into the lablgtk2
    default toplevel as it is not linkable with "lablgtksourceview2".

2009.05.21 [Jacques]
  * Apply Anil Madhavapeddy patch for lablgladecc2 -hide-default

2009.05.18 [Benjamin]
  * Make and install dynamic cmxs objects when available.
  * Fix compilation bug for ml_panel.c (Richard Jones message of 2009-02-06)

2009.05.12 [Jacques]
  * Merge new tooltip support from Moutinho's branch r1365
    (sorry for 1.5y delay...)
  * Merge tree DND from Moutinho's branch r1387 (1y delay...)

2009.05.08 [Jacques]
  * Add Gdk.Windowing.platform for platform dependent applications
  * Fix bug in Clist.set_pixmap when no mask given

2009.04.20 [Jacques]
  * Print backtrace if available when exception raised in signal callback.
    Requires ocaml 3.11. (suggested by Bart Jacobs)
  * Use "val virtual obj" in generated code. Requires ocaml 3.10.

2009.03.19 [Jacques]
  * In GtkAboutDialog, change internal property from "name" to "program-name"
    if version >= 2.12. The OO interface is left unchanged, since there is
    no conflict with #misc#name anyway.

2009.02.09 [Benjamin]
  * fix linking bug for older than 2.2 Gtk with g_io_channel_read_chars

2009.01.20 [Benjamin]
  * change handling of non existent properties.
    [Not_found] is no longer raised and [Invalid_argument prop_name] is
    used instead.
    No exception is raised by unknown dynamic property setters and a GLib
    warning is emitted.
    See the comments in src/gobject.mli in the local Property module.

2009.01.13 [Benjamin]
  * fix compilation issues with Gtk 2.4
2010-08-28 16:13:25 +00:00

15 lines
555 B
Text

$NetBSD: patch-aa,v 1.8 2010/08/28 16:13:25 wiz Exp $
--- src/Makefile.orig 2010-05-20 07:55:54.000000000 +0000
+++ src/Makefile
@@ -345,9 +345,7 @@ install:
if test $(THREADS_LIB) != no; \
then cp $(ALLTHOBJS:.cmo=.cmi) "$(INSTALLDIR)"; \
fi
- if test $(THREADS_LIB) = vm || test $(HAS_DLL_SUPPORT) != yes; \
- then cp lablgtktop$(XE) "$(INSTALLDIR)"; \
- fi
+ cp lablgtktop$(XE) "$(INSTALLDIR)"
cp -p *.h "$(INSTALLDIR)"
@if test -f lablgtk.cmxa; then $(MAKE) installopt; fi
@if test -f dlllablgtk2$(XS); then $(MAKE) installdll; fi