pkgsrc/sysutils/koncd/patches/patch-ab
bouyer e28cc06623 Add patch from Nick Hudson to detect util.h and getrawpartition() in libutil.
Chnage patch to cddata.cpp to use getrawpartition(), and enclose
NetBSD-specific changes in #ifdef __NetBSD/#endif so that it's easier
to send back to KDE folks.
2001-06-13 12:41:09 +00:00

15 lines
372 B
Text

$NetBSD: patch-ab,v 1.1 2001/06/13 12:41:09 bouyer Exp $
--- configure.in.in.orig Sat Mar 31 14:57:18 2001
+++ configure.in.in
@@ -2,3 +2,10 @@
AM_INIT_AUTOMAKE(koncd,0.7.1)
+AC_CHECK_HEADER(util.h,
+ AC_CHECK_LIB(util, getrawpartition, [
+ AC_DEFINE(HAVE_GETRAWPARTITION, 1, [Define if getrawpartition exists])
+ LIBUTIL="-lutil"]
+ )
+)
+AC_SUBST(LIBUTIL)