pkgsrc/math/ocaml-num/patches/patch-src_Makefile
jaapb 9949ca6d22 Added package math/ocaml-num.
This legacy library for arbitrary-precision integer and rational arithmetic
was formerly part of the standard OCaml library, but has now been
spun off.
2018-01-10 16:29:44 +00:00

17 lines
535 B
Text

$NetBSD: patch-src_Makefile,v 1.1 2018/01/10 16:29:44 jaapb Exp $
Use DESTDIR
--- src/Makefile.orig 2017-10-13 16:43:54.000000000 +0000
+++ src/Makefile
@@ -84,9 +84,9 @@ TOINSTALL_STUBS=dllnums.$(SO)
install:
$(OCAMLFIND) install num META
- $(INSTALL_DATA) $(TOINSTALL) $(STDLIBDIR)
+ $(INSTALL_DATA) $(TOINSTALL) ${DESTDIR}$(STDLIBDIR)
ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
- $(INSTALL_DLL) $(TOINSTALL_STUBS) $(STDLIBDIR)/stublibs
+ $(INSTALL_DLL) $(TOINSTALL_STUBS) ${DESTDIR}$(STDLIBDIR)/stublibs
endif
uninstall: