Release v1.41.0 This release contains refinements, improvements, and bug fixes, with highlights listed below. Core De-experimentalize XdsCredentials and XdsServerCredentials API. xDS: Remove environmental variable guard for security. xDS Security: Use new way to fetch certificate provider plugin instance config. xDS server serving status: Use a struct to allow more fields to be added in the future. Annotate impl/codegen with IWYU pragmas. Update submodule envoy-api to origin/main. Upgrade third_party/protobuf to v3.17.3. update submodule boringssl-with-bazel with origin/master-with-bazel. Delete libuv-iomgr implementation and GRPC_UV build option. Allow access to Google API regional endpoints via Google Default Credentials. Remove GPR_*_TLS macros except PTHREAD. Limit initial window size increases and per-stream window delta. C++ Bump version to v1.41.0-pre1. De-experimentalize XdsServerBuilder. C++ opencensus filter: Fix point of creating context for overall call. Flag grpc++_test library testonly. Add note on officially supported platforms. Open census call attempt span name and attribute changes Open census call attempt span name and attribute changes. C# Backport 27382 to v1.41.x. [csharp] Fix error loading library grpc_csharp_ext.*.dll on windows with non-ASCII encoding. Annotate copied Content native lib items with package id to enable customization. Objective-C Objective-C: Fix issue with creating a Unix file socket. Python Use manylinux_2_17 instead of manylinux_2_24 tag for manylinux2014 aarch64 wheels. Add Python 3.10 drop 3.5. [Aio] Remove custom IO manager support.
13 lines
744 B
Text
13 lines
744 B
Text
$NetBSD: patch-CMakeLists.txt,v 1.11 2021/10/06 10:58:30 adam Exp $
|
|
|
|
--- CMakeLists.txt.orig 2020-02-04 17:04:33.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -254,7 +254,7 @@ function(protobuf_generate_grpc_cpp)
|
|
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}_mock.grpc.pb.h"
|
|
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}.pb.cc"
|
|
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}.pb.h"
|
|
- COMMAND ${_gRPC_PROTOBUF_PROTOC_EXECUTABLE}
|
|
+ COMMAND env LD_LIBRARY_PATH=${CMAKE_BINARY_DIR} DYLD_LIBRARY_PATH=${CMAKE_BINARY_DIR} ${_gRPC_PROTOBUF_PROTOC_EXECUTABLE}
|
|
ARGS --grpc_out=generate_mock_code=true:${_gRPC_PROTO_GENS_DIR}
|
|
--cpp_out=${_gRPC_PROTO_GENS_DIR}
|
|
--plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
|