pkgsrc/www/ap2-xslt2/patches/patch-ac
xtraeme aca495c729 Initial import of ap2-xslt2 (known as mod-xslt2).
mod-xslt2 is a server side module able to transform ``xml''
documents in ``html'' (or to any other format) before they
even get back to the browser.

mod-xslt2 main features include:

* Ability to parse generated xml (ability to parse the output of
  php or perl scripts).

* Ability to use the ``xslt'' indicated by the <?xml-stylesheet
  processing instruction.

* Ability to send back the xml file unparsed to the browser.

* Ability to fetch xslt or DTDs from scripts rather than from
  static files.

* Ability to fetch a different xslt depending on the content of
  the request headers, of the get parameters or the web server
  environment.

* Ability to allow xslt stylesheets to make use of these
  variables to generate output.

--
http://www.mod-xslt2.com/
2006-12-07 02:34:01 +00:00

18 lines
926 B
Text

$NetBSD: patch-ac,v 1.1.1.1 2006/12/07 02:34:01 xtraeme Exp $
--- sapi/apache2/Makefile.in.orig 2004-10-02 10:24:09.000000000 +0200
+++ sapi/apache2/Makefile.in 2006-12-07 03:05:49.000000000 +0100
@@ -92,12 +92,7 @@
install: mod_xslt.la install-stamp Makefile
install-stamp: mod_xslt.la Makefile
- test "x$$UID" = "x" || test "x$$UID" = "x0" || { echo 'You must be root!'; exit 1; }
- $(LIBTOOL) --mode=install $(INSTALL) $(STRIP) -D -o root -g root -m 0644 mod_xslt.la '$(DESTDIR)$(APXS_INSTALLDIR)'
- @echo Removing extra files...
- FILE=`grep dlname mod_xslt.la | sed -e "s/[^']*'\([^']*\).*/\1/"` && \
- find '$(DESTDIR)$(APXS_INSTALLDIR)' -name 'mod_xslt.*'|grep -v "$$FILE"|xargs rm -f && \
- echo '$(DESTDIR)$(APXS_INSTALLDIR)'/$(FILE) > install-stamp
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_LIB) mod_xslt.la '$(DESTDIR)$(APXS_INSTALLDIR)'
uninstall:
test -f install-stamp && rm -f `cat install-stamp`