pkgsrc/x11/pixman/patches/patch-ad
bjs 6d3f41ecce Update to version 0.11.10, a bug-fix release. In addition,
add a 'gen-symfile' target for regenerating the libtool
export symfile.  This should be run upon updating the package.
While here, silence needless autotools warnings and update
sse2 conditional in hacks.mk.

Changes since 0.11.8:

              Add depth 30 formats to pixman_format_supported_source.

              [sse2] Change pixman-sse to pass __mm128i args as
              pointers, so as not to

              Use CopyAreasse2, plus a compatibility fix

              Use hidden attribute for private functions when
              compiling with Sun Studio

              Minor portability fixes
              Post-release version-bump
              Update RELEASING and release targets in Makefile.am
              Fix typo in sse2 configure logic
              TODO
              Don't require GCC 4.2 on x86-64
              Bug 16921. MMX and SSE2 intrinsics not enabled when
              compiling with Intel'
              Remove use of MMX extensions.
              Be consistent in naming SSE2 related things SSE2
              A few other renamings of SSE->SSE2
              Rename pixman-sse.h pixman-sse2.h
              Make sure pixman-combine{32,64}.h are disted
              Use error instead of #error in a couple of other places
              Check for __sun || __sun in pixman.h. Update TODO
              Bump release
              Update RELEASING

              Add sys/inttypes.h include for AIX
2008-09-06 20:09:15 +00:00

26 lines
704 B
Text

$NetBSD: patch-ad,v 1.4 2008/09/06 20:09:16 bjs Exp $
--- configure.ac.orig 2008-09-06 06:06:45.000000000 -0400
+++ configure.ac
@@ -109,14 +109,14 @@ dnl ====================================
dnl -fvisibility stuff
have_gcc4=no
-AC_MSG_CHECKING(for -fvisibility)
-AC_COMPILE_IFELSE([
-#if defined(__GNUC__) && (__GNUC__ >= 4)
-#else
-error Need GCC 4.0 for visibility
-#endif
+dnl AC_MSG_CHECKING(for -fvisibility)
+dnl AC_COMPILE_IFELSE([
+dnl #if defined(__GNUC__) && (__GNUC__ >= 4)
+dnl #else
+dnl error Need GCC 4.0 for visibility
+dnl #endif
int main () { return 0; }
-], have_gcc4=yes)
+dnl ], have_gcc4=yes)
if test "x$have_gcc4" = "xyes"; then
CFLAGS="$CFLAGS -fvisibility=hidden"