use other, better ones from pkgsrc through ncursesw/buildlink3.mk. + Add a configure script that lightly probes the system and write out some system-specific definitions for the Makefile. This should fix PR pkg/29425. + Add necessary includes (<string.h> and <unistd.h>) to global.h to do silly C things like prototype functions before you use them. Remove the unnecessary patches to lots of *.c files that added these same headers. + Include <string.h> in ss.c because it doesn't include global.h. + Move HTML documentation into ${PREFIX}/share/doc. Bump the PKGREVISION to 2.
10 lines
180 B
Text
10 lines
180 B
Text
$NetBSD: patch-al,v 1.1 2008/02/29 20:53:02 jlam Exp $
|
|
|
|
--- ss.c.orig 1996-09-05 06:11:24.000000000 -0400
|
|
+++ ss.c
|
|
@@ -26,4 +26,5 @@
|
|
*/
|
|
|
|
+#include <string.h>
|
|
#include "ss.h"
|
|
|