pkgsrc/multimedia/handbrake/patches/patch-ah
jmcneill 684be9f2d4 Import handbrake version 0.9.3.
HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded video
transcoder, available for MacOS X, NetBSD, Linux and Windows.

Supported sources:
 * Any DVD-like source: VIDEO_TS folder, DVD image or real DVD
   (unencrypted--protection methods including CSS are not supported internally
   and must be handled externally with third-party software and libraries),
   and some .VOB and .TS files
 * Most any multimedia file it can get libavformat to read and libavcodec to
   decode.

Outputs:
 * File format: MP4, MKV, AVI or OGM
 * Video: MPEG-4, H.264, or Theora (1 or 2 passes or constant quantizer/rate
   encoding)
 * Audio: AAC, MP3, Vorbis or AC-3 pass-through (supports encoding of several
   audio tracks)

Misc features:
 * Chapter selection
 * Basic subtitle support (burned into the picture)
 * Integrated bitrate calculator
 * Picture deinterlacing, cropping and scaling
 * Grayscale encoding
2009-01-21 14:15:15 +00:00

16 lines
530 B
Text

$NetBSD: patch-ah,v 1.1.1.1 2009/01/21 14:15:15 jmcneill Exp $
--- test/Makefile.orig 2009-01-20 21:27:22.000000000 -0500
+++ test/Makefile 2009-01-20 21:27:40.000000000 -0500
@@ -15,7 +15,11 @@ ifeq ($(findstring CYGWIN_NT,$(SYSTEM)),
LIBS2 += $(CYGLIBS:%=../contrib/lib/libz.a) $(CYGLIBS:%=../contrib/lib/libbz2.a)
endif
+ifeq ($(SYSTEM),NetBSD)
+LDFLAGS += $(LIBS2) -lbz2
+else
LDFLAGS += $(LIBS2) -lbz2 -ldl
+endif
../HandBrakeCLI: test.c parsecsv.c $(LIBS2)
@CMD="$(CC) $(CFLAGS) -o test.o -c test.c"; $$CMD || \