c38fda8df4
it modifies resulting shared object and regardless it worked before or not, it should be rebuild.
15 lines
986 B
Text
15 lines
986 B
Text
$NetBSD: patch-ah,v 1.2 2013/06/30 11:35:23 sno Exp $
|
|
|
|
Fixing missing RPATH for perl bindings
|
|
|
|
--- bindings/perl/Makefile.PL.in.orig 2009-07-24 19:55:09 +0300
|
|
+++ bindings/perl/Makefile.PL.in 2009-07-24 19:58:01 +0300
|
|
@@ -6,7 +6,7 @@ use Cwd "abs_path";
|
|
|
|
my %attributs = (NAME => 'PreludeEasy',
|
|
INC => '-I@top_srcdir@ -I@top_builddir@/src/include -I@top_srcdir@/src/include -I@top_builddir@/src/libprelude-error -I@top_srcdir@/bindings/c++/include -I@top_srcdir@/libmissing -I@top_builddir@/libmissing',
|
|
- LIBS => ["-L@top_builddir@/src/.libs -lprelude -L@top_builddir@/bindings/c++/.libs -lpreludecpp", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
|
|
+ LIBS => ["-L@top_builddir@/../.buildlink/lib -lprelude -lpreludecpp @LIBPRELUDE_LIBS@", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
|
|
LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags}");
|
|
|
|
if ( abs_path("@top_srcdir@") ne abs_path("@top_builddir@") ) {
|