pkgsrc/graphics/hp2xx/patches/patch-ab
seb 66111c6d15 Introduce new framework for handling info files generation and installation.
Summary of changes:
- removal of USE_GTEXINFO
- addition of mk/texinfo.mk
- inclusion of this file in package Makefiles requiring it
- `install-info' substituted by `${INSTALL_INFO}' in PLISTs
- tuning of mk/bsd.pkg.mk:
    removal of USE_GTEXINFO
    INSTALL_INFO added to PLIST_SUBST
    `${INSTALL_INFO}' replace `install-info' in target rules
    print-PLIST target now generate `${INSTALL_INFO}' instead of `install-info'
- a couple of new patch files added for a handful of packages
- setting of the TEXINFO_OVERRIDE "switch" in packages Makefiles requiring it
- devel/cssc marked requiring texinfo 4.0
- a couple of packages Makefiles were tuned with respect of INFO_FILES and
  makeinfo command usage

See -newly added by this commit- section 10.24 of Packages.txt for
further information.
2002-02-18 15:14:00 +00:00

87 lines
2.5 KiB
Text

$NetBSD: patch-ab,v 1.6 2002/02/18 15:14:21 seb Exp $
--- Makefile.orig Fri Feb 15 14:23:08 2002
+++ Makefile
@@ -28,13 +28,13 @@
CHMOD = chmod
CP = cp
-MKINFO = makeinfo
+MKINFO = $(MAKEINFO)
RMCMD = rm -f
STRIP = strip
# Installation sites (GNU conventions):
#
-prefix = /usr/local
+prefix = ${PREFIX}
bindir = $(prefix)/bin
includedir = $(prefix)/include
mandir = $(prefix)/man
@@ -44,12 +44,12 @@
# CC and CFLAGS set for gcc, but any ANSI-C compiler should work.
# For non-gcc compilers, simply set CFLAGS = -O (to start with)
#
-CC = gcc
-CFLAGS = -O2 -Wall -ansi -fstrength-reduce -finline-functions
+#CC = gcc
+CFLAGS+= -Wall -ansi -fstrength-reduce -finline-functions
-LFLAGS = # only sometimes needed; see below for examples
-CPPFLAGS = -I. # only sometimes needed; see below for examples
-BINDCMD = # only needed for EMX and DJGPP DOS extenders
+LFLAGS = -Wl,-R${X11BASE}/lib -L${X11BASE}/lib -Wl,-R${LOCALBASE}/lib -L${LOCALBASE}/lib # only sometimes needed; see below for examples
+CPPFLAGS = -I. -I${X11BASE}/include -I${LOCALBASE}/include # only sometimes needed; see below for examples
+BINDCMD = echo # only needed for EMX and DJGPP DOS extenders
@@ -62,7 +62,7 @@
#
DEFINES = -DUNIX -DHAS_UNIX_X11
PREVIEWER = to_x11
-ALL_LIBS = -lX11 -lm # Maybe -lX instead of -lX11 is needed?
+ALL_LIBS = -lX11 -lm -lz -lpng -ltiff -ljpeg
#
# Generic UNIX, no previewer
#
@@ -182,14 +182,14 @@
EX_DEFS =
#
# PNG support (requires -lpng and -lz on the ALL_LIBS line)
-#EX_SRC = png.c to_png.c
-#EX_OBJ = png.o to_png.o
-#EX_DEFS= -DPNG
+EX_SRC+= png.c to_png.c
+EX_OBJ+= png.o to_png.o
+EX_DEFS+= -DPNG
#
# TIFF support (requires -ltiff and possibly -lz on the ALL_LIBS line)
-#EX_SRC = to_tif.c
-#EX_OBJ = to_tif.o
-#EX_DEFS = -DTIF
+EX_SRC+= to_tif.c
+EX_OBJ+= to_tif.o
+EX_DEFS+= -DTIF
#
# Include extras:
# EX_SRC = to_pic.c to_pac.c
@@ -305,15 +305,11 @@
install: install-bin install-info install-man
install-bin: $(PROGRAM)
- -$(STRIP) $(PROGRAM)
- $(CP) $(PROGRAM) $(bindir)
- $(CHMOD) 755 $(bindir)/$(PROGRAM)
+ ${BSD_INSTALL_PROGRAM} $(PROGRAM) $(bindir)
install-info: hp2xx.info
- $(CP) hp2xx.info $(infodir)
- $(CHMOD) 644 $(infodir)/hp2xx.info
+ ${BSD_INSTALL_MAN} hp2xx.info $(infodir)
install-man: ../doc/hp2xx.1
- $(CP) ../doc/hp2xx.1 $(man1dir)
- $(CHMOD) 644 $(man1dir)/hp2xx.1
+ ${BSD_INSTALL_MAN} ../doc/hp2xx.1 $(man1dir)