pkgsrc/databases/postgresql10/patches/patch-src_backend_Makefile
adam db8cb73458 postgresql10: added version 10.0
Major enhancements in PostgreSQL 10 include:

Logical replication using publish/subscribe
Declarative table partitioning
Improved query parallelism
Significant general performance improvements
Stronger password authentication based on SCRAM-SHA-256
Improved monitoring and control
The above items are explained in more detail in the sections below.
2017-10-23 20:33:49 +00:00

24 lines
884 B
Text

$NetBSD: patch-src_backend_Makefile,v 1.1 2017/10/23 20:33:49 adam Exp $
--- src/backend/Makefile.orig 2017-10-02 21:09:15.000000000 +0000
+++ src/backend/Makefile
@@ -17,6 +17,10 @@ subdir = src/backend
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
+CFLAGS+= $(DL_CFLAGS)
+LDFLAGS+= $(DL_LDFLAGS)
+LIBS+= $(DL_LIBS)
+
SUBDIRS = access bootstrap catalog parser commands executor foreign lib libpq \
main nodes optimizer port postmaster regex replication rewrite \
statistics storage tcop tsearch utils $(top_builddir)/src/timezone
@@ -119,6 +123,8 @@ submake-errcodes: $(top_builddir)/src/in
$(top_builddir)/src/port/libpgport_srv.a: | submake-libpgport
+$(top_builddir)/src/common/libpgcommon_srv.a: | submake-libpgport
+
# The postgres.o target is needed by the rule in Makefile.global that
# creates the exports file when MAKE_EXPORTS = true.