pkgsrc/graphics/osg/patches/patch-ae
adam 343ff354d7 Changes 3.0.1:
* OpenGL ES 1.1, and OpenGL ES 2.0 support
* OpenGL 3.x and 4.x support along with associated OpenGL extensions
* Supoort for Android on tablets and phones
* Support for IOS on tablets and phones (end users applications have already
  been accepted on the App Store)
* Introduction of Present3D application for immersive 3D presentations
* New extensible serializers that provide new .osgb binary, .osgt ascii and
  .osgx xml file native formats
* New generalized serializable metadata architecture
* New osgQt library that makes it straight forward to integrate !OpenSceneGraph
  with Qt, including web browsing via QWebKit.
* New FBX plugin based on the Audodesk FBX DSK that enables reading of the the
  .fbx 3D authoring and interchange format
* New directshow plugin for handling movies under Windows
* New pov plugin for exporting a scene to POV-Ray format, enabling use of
  POV-Ray to do photo-realistic ray tracing
* New ply plugin for reading ply files
* Improvements to osgText that enable bevelling of 3D text and highter quality
  2D fonts
* Improvements to osgVolume enabling high quality ray traced volume rendering
* Improvements to osgManipulator making it more flexible
* Improvements to osgParticle to support shader based particle effects
* Revamped 3ds plugin for reading and writing of .3ds files
* Revamped dxf plugin for reading and writing of .dxf files
* Support for Cocoa and 64bit OSX build
* Improved thread safety and efficiency of database paging
* New Texture and buffer object pools for efficiently managing GL object
  resources
2012-03-07 16:27:35 +00:00

19 lines
540 B
Text

$NetBSD: patch-ae,v 1.2 2012/03/07 16:27:35 adam Exp $
PkgSrc does not use lib64.
--- CMakeLists.txt.orig 2011-07-31 07:50:34.000000000 +0000
+++ CMakeLists.txt
@@ -586,12 +586,6 @@ IF(CYGWIN)
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG")
ENDIF()
-IF(UNIX AND NOT WIN32 AND NOT APPLE)
- IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
- MARK_AS_ADVANCED(LIB_POSTFIX)
- ENDIF()
-ENDIF()
IF(NOT DEFINED LIB_POSTFIX)
SET(LIB_POSTFIX "")
ENDIF()