* Emacs fixes * The ++ and -- operators now work for indexed matrices * The built-in variable argv is now a list of strings instead of a string vec. * The new built-in variable `crash_dumps_octave_core' controls whether Octave writes user variables to the file `octave-core' when it crashes or is killed by a signal. * Loops of the form `for i = STRING ... endfor' are now allowed. * It is now possible to set the iteration limit for lsode using lsode_options ("step limit", N). * New functions * The save command now accepts the option -append to save the variables at the end of the file, leaving the existing contents. * New command-line option --no-history (also available using the single character option -H) inhibits saving command history. * The built-in variable `PWD' has been removed. * New operators. * New built-in data types. * Commas in global statements are no longer special. * It is now possible to declare static variables that retain their values across function calls. More --> See "NEWS"
13 lines
507 B
Text
13 lines
507 B
Text
$NetBSD: patch-ae,v 1.3 2003/12/04 11:15:37 adam Exp $
|
|
|
|
--- libcruft/misc/Makefile.in.orig 2003-11-20 13:50:06.000000000 +0100
|
|
+++ libcruft/misc/Makefile.in
|
|
@@ -62,7 +62,7 @@ XCC = $(patsubst -O%, , $(CC))
|
|
XALL_CFLAGS = $(patsubst -O%, , $(ALL_CFLAGS))
|
|
|
|
machar.o: $(srcdir)/machar.c
|
|
- $(XCC) -c $(CPPFLAGS) $(XALL_CFLAGS) -DDP $<
|
|
+ ${LIBTOOL} --mode=compile $(XCC) -c $(CPPFLAGS) $(XALL_CFLAGS) -DDP $<
|
|
|
|
pic/machar.o: $(srcdir)/machar.c
|
|
$(XCC) -c $(CPPFLAGS) $(CPICFLAG) $(XALL_CFLAGS) -DDP $< -o $@
|