07d68f1cec
-additions: -GtkPlot: display grids on top/below data New function gtk_plot_set_pc New signal "tick_label" to retrieve axes tick labels New functions to handle axes labels -GtkPlotDT: delaunay triangulization algorithm -GtkSheet: New function gtk_sheet_get_entry_widget Background colors and grid handling -GtkPlotPC: New function gtk_plot_pc_set_viewport -GtkPlotData: New alternative to retrieve data points trough a callback function Scale points size New functions to autoscale gradient according to field gtk_plot_data_get_point() to retrieve values Data markers -GtkPlotSurface: Use new Delaunay triangulization algorithm New functions to colour the surface using a gradient proportional to the height field -GtkPlotCSurface: Gradient with sublevels -GtkPlotCanvas: New child: CANVAS_MARKERS New selection stretegy New function gtk_plot_set_pc gtk_plot_canvas_freeze/thaw methods -fixes: -build system -memory leaks -etc -add a buildlink.mk
12 lines
310 B
Text
12 lines
310 B
Text
$NetBSD: patch-ac,v 1.2 2002/01/09 14:46:52 drochner Exp $
|
|
|
|
--- gtkextra/gtkplotps.c.orig Wed Jan 9 12:09:03 2002
|
|
+++ gtkextra/gtkplotps.c Wed Jan 9 12:09:20 2002
|
|
@@ -34,7 +34,6 @@
|
|
#include <ctype.h>
|
|
#include <time.h>
|
|
#include <gtk/gtk.h>
|
|
-#include <wctype.h>
|
|
#include <locale.h>
|
|
|
|
#include "gtkplot.h"
|