41 lines
1.6 KiB
Text
41 lines
1.6 KiB
Text
$NetBSD: patch-ab,v 1.1 2010/02/08 05:18:37 dholland Exp $
|
|
|
|
DESTDIR support
|
|
|
|
--- ../binutils-2.12.1/intl/Makefile.in.orig 2002-03-08 19:25:51.000000000 +0000
|
|
+++ ../binutils-2.12.1/intl/Makefile.in
|
|
@@ -115,26 +115,26 @@ install-exec: all
|
|
if test "$(PACKAGE)" = "gettext" \
|
|
&& test '@INTLOBJS@' = '$(GETTOBJS)'; then \
|
|
if test -r $(MKINSTALLDIRS); then \
|
|
- $(MKINSTALLDIRS) $(libdir) $(includedir); \
|
|
+ $(MKINSTALLDIRS) ${DESTDIR}$(libdir) ${DESTDIR}$(includedir); \
|
|
else \
|
|
- $(top_srcdir)/mkinstalldirs $(libdir) $(includedir); \
|
|
+ $(top_srcdir)/mkinstalldirs ${DESTDIR}$(libdir) ${DESTDIR}$(includedir); \
|
|
fi; \
|
|
- $(INSTALL_DATA) intlh.inst $(includedir)/libintl.h; \
|
|
- $(INSTALL_DATA) libintl.a $(libdir)/libintl.a; \
|
|
+ $(INSTALL_DATA) intlh.inst ${DESTDIR}$(includedir)/libintl.h; \
|
|
+ $(INSTALL_DATA) libintl.a ${DESTDIR}$(libdir)/libintl.a; \
|
|
else \
|
|
: ; \
|
|
fi
|
|
install-data: all
|
|
if test "$(PACKAGE)" = "gettext"; then \
|
|
if test -r $(MKINSTALLDIRS); then \
|
|
- $(MKINSTALLDIRS) $(gettextsrcdir); \
|
|
+ $(MKINSTALLDIRS) ${DESTDIR}$(gettextsrcdir); \
|
|
else \
|
|
- $(top_srcdir)/mkinstalldirs $(gettextsrcdir); \
|
|
+ $(top_srcdir)/mkinstalldirs ${DESTDIR}$(gettextsrcdir); \
|
|
fi; \
|
|
- $(INSTALL_DATA) VERSION $(gettextsrcdir)/VERSION; \
|
|
+ $(INSTALL_DATA) VERSION ${DESTDIR}$(gettextsrcdir)/VERSION; \
|
|
dists="$(DISTFILES.common)"; \
|
|
for file in $$dists; do \
|
|
- $(INSTALL_DATA) $(srcdir)/$$file $(gettextsrcdir)/$$file; \
|
|
+ $(INSTALL_DATA) $(srcdir)/$$file ${DESTDIR}$(gettextsrcdir)/$$file; \
|
|
done; \
|
|
else \
|
|
: ; \
|