7ed1ce4c8d
Socket++ is a C++ class library that provides you with an iostream based interface to sockets.
22 lines
686 B
Text
22 lines
686 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2005/03/27 17:45:38 wiz Exp $
|
|
|
|
--- test/Makefile.in.orig 2003-03-18 16:47:57.000000000 +0100
|
|
+++ test/Makefile.in
|
|
@@ -40,7 +40,7 @@ DEPEND_SOURCES = $(srcdir)/*.C
|
|
.SUFFIXES: .o .C .cc
|
|
|
|
.cc.o .C.o:
|
|
- $(CXX) -c $(CXXFLAGS) -I$(srcdir) -I$(srcdir)/.. -I$(srcdir)/../socket++ $<
|
|
+ $(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) -I$(srcdir) -I$(srcdir)/.. -I$(srcdir)/../socket++ $<
|
|
|
|
.PHONY: check
|
|
check: testall.out
|
|
@@ -62,7 +62,7 @@ testall.out: $(TESTS)
|
|
./testall > testall.out
|
|
|
|
$(TESTS): $(TESTOBJS)
|
|
- $(CXX) $(CXXFLAGS) -o $@ $@.o $(LIBS)
|
|
+ $(LIBTOOL) --mode=link $(CXX) $(CXXFLAGS) -o $@ $@.o $(LIBS)
|
|
|
|
update-version:
|
|
for i in $(TESTSRCS); \
|