pkgsrc/www/py-curl/patches/patch-aa
recht 0d32790d4b update to PycURL 7.10.8
changes:

* Added support for these new libcurl 7.10.8 features:
  CURLOPT_FTP_RESPONSE_TIMEOUT, CURLOPT_IPRESOLVE,
  CURLOPT_MAXFILESIZE,
  CURLINFO_HTTPAUTH_AVAIL, CURLINFO_PROXYAUTH_AVAIL,
  CURL_IPRESOLVE_* constants.

* Added support for these new libcurl 7.10.7 features:
  CURLOPT_FTP_CREATE_MISSING_DIRS, CURLOPT_PROXYAUTH,
  CURLINFO_HTTP_CONNECTCODE.

* Added missing CURLOPT_ENCODING option (patch by Martijn
  Boerwinkel <xim@xs4all.nl>)
2004-01-23 23:08:01 +00:00

16 lines
657 B
Text

$NetBSD: patch-aa,v 1.3 2004/01/23 23:08:01 recht Exp $
--- setup.py.orig 2003-11-04 17:12:34.000000000 +0100
+++ setup.py 2004-01-24 00:02:39.000000000 +0100
@@ -136,9 +136,9 @@
# a list of tuples with (path to install to, a list of local files)
data_files = []
if sys.platform == "win32":
- datadir = os.path.join("doc", PACKAGE)
+ datadir = os.path.join("doc", PACKAGE + sys.version[0:3])
else:
- datadir = os.path.join("share", "doc", PACKAGE)
+ datadir = os.path.join("share", "doc", PACKAGE + sys.version[0:3])
#
files = ["ChangeLog", "COPYING", "INSTALL", "README", "TODO",]
if files: