pkgsrc/security/dsniff/patches/patch-ac
apb add6a683f6 Make dsniff and dsniff-nox11 build on NetBSD-current:
* In dsniff-nox11/Makefile, add a post-configure target to move
  missing/sys/queue.h out of the way if the configure script
  found a real sys/queue.h.
* Add patches to #include <string.h> in some files where I noticed warnings.

Bump PKGREVISION for both dsniff and dsniff-nox11.
2008-10-01 08:43:09 +00:00

21 lines
503 B
Text

$NetBSD: patch-ac,v 1.2 2008/10/01 08:43:09 apb Exp $
--- arp.c.orig 2000-11-14 17:51:03.000000000 +0200
+++ arp.c
@@ -17,7 +17,7 @@
#include <sys/sysctl.h>
#include <net/if_dl.h>
#include <net/route.h>
-#ifdef __FreeBSD__ /* XXX */
+#if defined(__FreeBSD__) || defined(__DragonFly__) /* XXX */
#define ether_addr_octet octet
#endif
#else /* !BSD */
@@ -32,6 +32,7 @@
#include <netinet/if_ether.h>
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <unistd.h>
#ifdef BSD