pkgsrc/devel/readline/patches/patch-examples_Makefile.in
wiz d9c4ba1f85 readline: update to 8.0.
This is a terse description of the new features added to readline-8.0 since
the release of readline-7.0.

New Features in Readline

a. Non-incremental vi-mode search (`N', `n') can search for a shell pattern, as
   Posix specifies (uses fnmatch(3) if available).

b. There are new `next-screen-line' and `previous-screen-line' bindable
   commands, which move the cursor to the same column in the next, or previous,
   physical line, respectively.

c. There are default key bindings for control-arrow-key key combinations.

d. A negative argument (-N) to `quoted-insert' means to insert the next N
   characters using quoted-insert.

e. New public function: rl_check_signals(), which allows applications to
   respond to signals that readline catches while waiting for input using
   a custom read function.

f. There is new support for conditionally testing the readline version in an
   inputrc file, with a full set of arithmetic comparison operators available.

g. There is a simple variable comparison facility available for use within an
   inputrc file. Allowable operators are equality and inequality; string
   variables may be compared to a value; boolean variables must be compared to
   either `on' or `off'; variable names are separated from the operator by
   whitespace.

h. The history expansion library now understands command and process
   substitution and extended globbing and allows them to appear anywhere in a
   word.

i. The history library has a new variable that allows applications to set the
   initial quoting state, so quoting state can be inherited from a previous
   line.

j. Readline now allows application-defined keymap names; there is a new public
   function, rl_set_keymap_name(), to do that.

k. The "Insert" keypad key, if available, now puts readline into overwrite
   mode.
2019-02-13 22:49:02 +00:00

37 lines
1.1 KiB
Text

$NetBSD: patch-examples_Makefile.in,v 1.5 2019/02/13 22:49:02 wiz Exp $
Patch to link correctly against libtool built libs.
Note: to make the patch smaller this uses "CC" to link and "REALCC"
to compile. There's only one compile line and many link lines.
--- examples/Makefile.in.orig 2018-09-18 16:11:14.000000000 +0000
+++ examples/Makefile.in
@@ -46,7 +46,8 @@ OBJEXT = @OBJEXT@
DESTDIR =
DEFS = @DEFS@
-CC = @CC@
+REALCC = $(LIBTOOL) --mode=compile @CC@
+CC = $(LIBTOOL) --mode=link @CC@
CFLAGS = @CFLAGS@
LOCAL_CFLAGS = @LOCAL_CFLAGS@ -DREADLINE_LIBRARY -DRL_LIBRARY_VERSION='"$(RL_LIBRARY_VERSION)"'
CPPFLAGS = @CPPFLAGS@
@@ -60,14 +61,14 @@ LDFLAGS = -g -L.. @LDFLAGS@ $(ASAN_LDFLA
ASAN_XCFLAGS = -fsanitize=address -fno-omit-frame-pointer
ASAN_XLDFLAGS = -fsanitize=address
-READLINE_LIB = ../libreadline.a
-HISTORY_LIB = ../libhistory.a
+READLINE_LIB = ../libreadline.la
+HISTORY_LIB = ../libhistory.la
TERMCAP_LIB = @TERMCAP_LIB@
.c.o:
${RM} $@
- $(CC) $(CCFLAGS) -c $<
+ $(REALCC) $(CCFLAGS) -c $<
SOURCES = excallback.c fileman.c histexamp.c manexamp.c rl-fgets.c rl.c \
rlbasic.c rlcat.c rlevent.c rlptytest.c rltest.c rlversion.c \