pkgsrc/chat/eggdrop/patches/patch-ac
adam 4ee409413a Changes 1.6.17:
- Lots of doc updates.
  - Added a "stripcodes" Tcl command. See doc/tcl-commands.doc for more
    information.
  - Bot idx's should be considered valid to tcl_valididx.
  - Always try to detect shared Tcl libraries before static ones.
  - We now correctly differentiate the +l user flag from the +l bot flag.
  - Cleaned up modules.c and the module configure stuff quite a bit.
  - Detect Tcl in $HOME/lib and $HOME/tcl/lib first, as to make it easier
    to allow users to override the system's Tcl version.
  - We now support module loading under Darwin (Mac OS X) and NeXT Step.
  - Don't try to call tcl_notes if the notes module isn't loaded.
  - Show a more descriptive error message when a listen socket can't be opened.
  - Fixed Tcl encoding issues with .tcl and .set.
  - Added a set of Finnish language files and a Finnish MOTD.
  - time_t isn't unsigned, and therefor %lu should not be used as a
    conversion specifier.
  - Fixed a gcc warning in dcc.c.
  - Added support for Quakenet channel modes.
  - Removed an invalid killsock() in dcc.c.
  - Fixed extra spaces being written to chan file.
  - Reworked 'make config' / module configure process.
  - Op (+o) implies halfop (+l) now.
  - Cleaned up and optimized rmspace() and fixfrom().
  - Updated recomended Tcl version to 8.4.6.
  - Fix behavior of the BCST bind. BCST is now correctly triggered for
    dccbroadcasts, as well as when a bot "says" something on a channel.
    See doc/tcl-commands.doc for more information.
  - Remove some unneeded casts.
  - Fixed performance issues with mv/cp when a lot of files are in the
    file area.
  - Typo in doc/COMPILING-FAQ. It's LD_LIBRARY_PATH, not LB_LIBRARY_PATH.
  - Fix a possible issue with ident code.
  - Don't let .tcl mkdir create duplicate filedb entries.
  - Fixed a compile error related to varargs when using old Tcl versions.
  - Fixed a compile error on systems that don't have socklen_t.
  - Suppress configure warnings on systems that use newer versions of GNU
    coreutils.
2004-12-03 12:15:54 +00:00

30 lines
1 KiB
Text

$NetBSD: patch-ac,v 1.4 2004/12/03 12:15:54 adam Exp $
--- src/Makefile.in.orig 2004-07-25 11:17:34.000000000 +0000
+++ src/Makefile.in
@@ -4,6 +4,7 @@
SHELL = @SHELL@
top_srcdir = @top_srcdir@
srcdir = @srcdir@
+prefix = @prefix@
VPATH = @srcdir@
@SET_MAKE@
@@ -16,7 +17,7 @@ CC = @CC@
LD = @CC@
STRIP = @STRIP@
CFLAGS = @CFLAGS@ -I.. -I$(top_srcdir) @DEFS@ $(CFLGS)
-CPPFLAGS = @CPPFLAGS@
+CPPFLAGS = @CPPFLAGS@ '-D__PREFIX__="@prefix@"' '-D__PKG_SYSCONFDIR__="@sysconfdir@"'
eggdrop_objs = bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o dcc.o \
dccutil.o dns.o flags.o language.o match.o main.o mem.o misc.o misc_file.o \
@@ -37,7 +38,7 @@ doofus:
@echo "Linking eggdrop $(EGGBUILD)."
@echo ""
@touch mod/mod.xlibs
- $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
+ $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLDFLAGS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
$(STRIP) ../$(EGGEXEC)
@echo ""
@echo "Successful compile: $(EGGEXEC)"