46c042ccc9
* Merged Athena telnetd changes for creating a new option for requiring encryption. * Add implementation of the RPCSEC_GSS authentication flavor to the RPC library. * The kadmind4 backwards-compatibility admin server and the v5passwdd backwards-compatibility password-changing server have been removed. * Thread safety for krb5 libraries. * Yarrow code now uses AES. * Merged Athena changes to allow ftpd to require encrypted passwords. * Incorporate gss_krb5_set_allowable_enctypes() and gss_krb5_export_lucid_sec_context(), which are needed for NFSv4. * Fix heap buffer overflow in password history mechanism. [MITKRB5-SA-2004-004]
15 lines
621 B
Text
15 lines
621 B
Text
$NetBSD: patch-ac,v 1.2 2005/04/10 07:15:25 jlam Exp $
|
|
|
|
--- appl/telnet/telnetd/Makefile.in.orig 2004-09-22 18:59:45.000000000 -0400
|
|
+++ appl/telnet/telnetd/Makefile.in
|
|
@@ -60,8 +60,8 @@ OBJS= telnetd.o \
|
|
|
|
all:: telnetd
|
|
|
|
-telnetd: $(OBJS) $(PTY_DEPLIB) $(KRB4COMPAT_DEPLIBS) ../libtelnet/libtelnet.a
|
|
- $(CC_LINK) -o $@ $(OBJS) ../libtelnet/libtelnet.a $(PTY_LIB) $(UTIL_LIB) $(KRB4COMPAT_LIBS)
|
|
+telnetd: $(OBJS) $(PTY_DEPLIB) $(KRB4COMPAT_DEPLIBS) ../libtelnet/libtelnet$(DEPSTLIBEXT)
|
|
+ $(CC_LINK) -o $@ $(OBJS) ../libtelnet/libtelnet$(DEPSTLIBEXT) $(PTY_LIB) $(UTIL_LIB) $(KRB4COMPAT_LIBS)
|
|
|
|
clean::
|
|
$(RM) telnetd
|