pkgsrc/lang/gcc3/patches/patch-an
seb 1cd5dcea8a Make all gcc3-* packages use a single distinfo file from gcc3/distinfo and
a single patch directory from gcc3/patches/.
Also Move gcc3-c/{Makefile.common,language.mk} into gcc3/.
2004-04-10 15:47:08 +00:00

36 lines
1.2 KiB
Text

$NetBSD: patch-an,v 1.1 2004/04/10 15:47:08 seb Exp $
--- gcc/ada/i-cstrea.ads.orig 2002-10-23 01:33:26.000000000 -0600
+++ gcc/ada/i-cstrea.ads
@@ -179,9 +179,6 @@ package Interfaces.C_Streams is
function isatty (handle : int) return int;
- procedure mktemp (template : chars);
- -- The return value (which is just a pointer to template) is discarded
-
procedure rewind (stream : FILEs);
function setvbuf
@@ -191,11 +188,6 @@ package Interfaces.C_Streams is
size : size_t)
return int;
- procedure tmpnam (string : chars);
- -- The parameter must be a pointer to a string buffer of at least L_tmpnam
- -- bytes (the call with a null parameter is not supported). The returned
- -- value, which is just a copy of the input argument, is discarded.
-
function tmpfile return FILEs;
function ungetc (c : int; stream : FILEs) return int;
@@ -270,9 +262,7 @@ private
pragma Import (C, fseek);
pragma Import (C, ftell);
pragma Import (C, isatty);
- pragma Import (C, mktemp);
pragma Import (C, rewind);
- pragma Import (C, tmpnam);
pragma Import (C, tmpfile);
pragma Import (C, ungetc);
pragma Import (C, unlink);