pkgsrc/editors/gummi/patches/patch-src_Makefile.am
bsiegert d1b5c72788 Gummi 0.6.6 "We're still here" (January 27th, 2016):
Bugs fixed:

- Fix using predictable filenames in /tmp (CVE-2015-7758)
- Fix source id warnings during motion runtime
- Fix open-project crash due to missing file chooser title
- Fix synctex for input files with relative paths
- Add descriptive keywords to our desktop entry file
- Improvements to the bibliography detection regex
- Only allow loading tex files through file->open
- Desensitize cut/copy tools when no text is selected
- Various improvements to build system
- Removed deprecated code
2016-08-09 18:23:20 +00:00

13 lines
466 B
Text

$NetBSD: patch-src_Makefile.am,v 1.1 2016/08/09 18:23:20 bsiegert Exp $
--- src/Makefile.am.orig 2016-01-27 19:27:48.000000000 +0000
+++ src/Makefile.am
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
bin_PROGRAMS = gummi
AM_CFLAGS = $(GUI_CFLAGS) \
- -export-dynamic -Wall -O2 \
+ -Wl,-export-dynamic -Wall -O2 \
-DGUMMI_LIBS=\"$(libdir)/$(PACKAGE)\" \
-DGUMMI_DATA=\"$(datadir)/$(PACKAGE)\" \
-DGUMMI_LOCALES=\"$(datadir)/locale\"