c592fc7dfe
The Asterisk Development Team has announced the release of Asterisk 11.3.0. The release of Asterisk 11.3.0 resolves several issues reported by the community and would have not been possible without your participation. Thank you! The following is a sample of the issues resolved in this release: * --- Fix issue where chan_mobile fails to bind to first available port * --- Fix Queue Log Reporting Every Call COMPLETECALLER With "h" Extension Present * --- Retain XMPP filters across reconnections so external modules continue to function as expected. * --- Ensure that a declined media stream is terminated with a '\r\n' * --- Fix pjproject compilation in certain circumstances For a full list of changes in this release, please see the ChangeLog: http://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-11.3.0 Thank you for your continued support of Asterisk!
54 lines
1.9 KiB
Text
54 lines
1.9 KiB
Text
$NetBSD: patch-main_Makefile,v 1.2 2013/05/05 01:32:35 jnemeth Exp $
|
|
|
|
--- main/Makefile.orig 2013-01-18 21:10:23.000000000 +0000
|
|
+++ main/Makefile
|
|
@@ -89,6 +89,10 @@ ifeq ($(OSARCH),OpenBSD)
|
|
AST_LIBS+=-lcrypto -lpthread -lm $(EDITLINE_LIB)
|
|
endif
|
|
|
|
+ifeq ($(OSARCH),dragonfly)
|
|
+ AST_LIBS+=-lpthread
|
|
+endif
|
|
+
|
|
ifeq ($(OSARCH),SunOS)
|
|
AST_LIBS+=-lpthread -ldl -lrt -lnsl -lsocket -lresolv
|
|
ASTSSL_LIBS+=-L/opt/ssl/lib -L/usr/local/ssl/lib
|
|
@@ -215,9 +219,6 @@ ifeq ($(GNU_LD),1)
|
|
endif
|
|
$(ECHO_PREFIX) echo " [LD] $^ -> $@"
|
|
$(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(CC_LDFLAGS_SO) $^ $(CC_LIBS)
|
|
-ifneq ($(LDCONFIG),)
|
|
- $(LDCONFIG) $(LDCONFIG_FLAGS) .
|
|
-endif
|
|
|
|
$(ASTSSL_LIB): $(ASTSSL_LIB).$(ASTSSL_SO_VERSION)
|
|
$(LN) -sf $< $@
|
|
@@ -261,13 +262,13 @@ bininstall:
|
|
$(INSTALL) -m 755 $(MAIN_TGT) "$(DESTDIR)$(ASTSBINDIR)/"
|
|
ifeq ($(AST_ASTERISKSSL),yes)
|
|
ifeq ($(findstring darwin,$(OSARCH)),) # not Darwin
|
|
- $(INSTALL) -m 755 $(ASTSSL_LIB).$(ASTSSL_SO_VERSION) "$(DESTDIR)$(ASTLIBDIR)/"
|
|
- $(LN) -sf $(ASTSSL_LIB).$(ASTSSL_SO_VERSION) "$(DESTDIR)$(ASTLIBDIR)/$(ASTSSL_LIB)"
|
|
+ $(INSTALL) -m 755 $(ASTSSL_LIB).$(ASTSSL_SO_VERSION) "$(DESTDIR)$(PREFIX)/lib/"
|
|
+ $(LN) -sf $(ASTSSL_LIB).$(ASTSSL_SO_VERSION) "$(DESTDIR)$(PREFIX)/lib/$(ASTSSL_LIB)"
|
|
else # Darwin
|
|
$(INSTALL) -m 755 $(ASTSSL_LIB) "$(DESTDIR)$(ASTLIBDIR)/"
|
|
endif
|
|
ifneq ($(LDCONFIG),)
|
|
- $(LDCONFIG) $(LDCONFIG_FLAGS) "$(DESTDIR)$(ASTLIBDIR)/"
|
|
+ $(LDCONFIG) $(LDCONFIG_FLAGS) "$(DESTDIR)$(PREFIX)/lib/"
|
|
endif
|
|
endif
|
|
$(LN) -sf asterisk "$(DESTDIR)$(ASTSBINDIR)/rasterisk"
|
|
@@ -275,10 +276,7 @@ endif
|
|
binuninstall:
|
|
rm -f "$(DESTDIR)$(ASTSBINDIR)/$(MAIN_TGT)"
|
|
rm -f "$(DESTDIR)$(ASTSBINDIR)/rasterisk"
|
|
- rm -f "$(DESTDIR)$(ASTLIBDIR)/$(ASTSSL_LIB).$(ASTSSL_SO_VERSION)"
|
|
-ifneq ($(LDCONFIG),)
|
|
- $(LDCONFIG) $(LDCONFIG_FLAGS) "$(DESTDIR)$(ASTLIBDIR)/"
|
|
-endif
|
|
+ rm -f "$(DESTDIR)$(PREFIX)/lib/$(ASTSSL_LIB).$(ASTSSL_SO_VERSION)"
|
|
|
|
clean::
|
|
rm -f asterisk libasteriskssl.o
|