pkgsrc/editors/emacs20/patches/patch-bg

54 lines
1.4 KiB
Text

$NetBSD: patch-bg,v 1.1.1.1 2003/04/11 00:31:45 uebayasi Exp $
--- configure.in.orig Mon Jun 5 17:42:49 2000
+++ configure.in Tue Oct 22 15:59:01 2002
@@ -66,6 +66,8 @@
esac
with_x_toolkit=$val
])
+AC_ARG_WITH(ipv6,
+[ --with-ipv6 support IPv6 stack])
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessary, since pwd can
@@ -158,9 +160,13 @@
machine=hp9000s300 ;;
powerpc-apple-netbsd*) machine=macppc ;;
mips-*-netbsd*) machine=pmax ;;
+ mipsel-*-netbsd*) machine=pmax ;;
+ mipsev-*-netbsd*) machine=mips ;; # HF: what else?
ns32k-*-netbsd*) machine=ns32000 ;;
- sparc-*-netbsd*) machine=sparc ;;
+ powerpc-*-netbsd*) machine=macppc ;;
+ sparc*-*-netbsd*) machine=sparc ;;
vax-*-netbsd*) machine=vax ;;
+ arm*-*-netbsd*) machine=arm ;;
esac
;;
@@ -1594,6 +1600,14 @@
LIBS="-lXt $LIBS"
fi
AC_CHECK_LIB(Xmu, XmuConvertStandardSelection)
+ if test x$HAVE_X11XTR6 = xyes; then
+dnl Check if Xaw needs Xpm
+ LIBS="$LIBS -lXpm"
+ AC_CHECK_LIB(Xaw, XawPixmapsInitialize, [ LIBXPM="-lXpm" ], [ LIBXPM=""])
+ else
+ LIBXPM=""
+ fi
+ AC_SUBST(LIBXPM)
LIBS="$OLDLIBS"
fi
@@ -1747,6 +1761,10 @@
AC_DEFINE(HAVE_AIX_SMT_EXP)
fi
+if test "x$with_ipv6" = xyes; then
+ AC_CHECK_FUNCS(getaddrinfo)
+fi
+
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"