pkgsrc/sysutils/bacula/patches/patch-src_stored_Makefile.in
jnemeth bc25c84b5b bacula: update to 9.6.6
Changelog for version 9.6.6

18Sep20
 - baculum: Fix displaying date and time on volume view page

17Sep20
 - baculum: Fix #2564 changing volume status to Read-Only

11Sep20
 - baculum: Fix saving multicombobox control values
 - baculum: Fix multicombobox and multitextbox controls to work with PHP 7.4

10Sep20
 - baculum: Fix #2562 displaying date and time in tables on Safari

30Aug20
 - Update copyright year

17Aug20
 - Clarify SD vbackup device error message
 - Fix MT2554 :update upload_cache call in dircmd.c

15Aug20
 - zero malloced memory when SMARTALLOC not enabled

09Aug20
 - baculum: Fix #2558 saving day or day range in schedule resource - reported by
  Jose Alberto

05Aug20
 - Fix MT2554 :upgrade upload_cache interface.

29Jun20
 - Eliminate compiler errors when smartalloc is turned off

28Jun20
 - baculum: Fix date formatter to work with PHP 7.4

27Jun20
 - baculum: Fix configure Bacula hosts page to work with PHP 7.4

25Jun20
 - baculum: Update Portuguese translations

24Jun20
 - baculum: Change colours in table headers and borders

20Jun20
 - baculum: Add remove runscript button

19Jun20
 - Fix #6366 About an issue with verify job level=DiskToCatalog
 - baculum: Close modal windows on pressing ESC key
 - baculum: Fix logout button on authorization failed page

18Jun20
 - baculum: Add local user authentication method support

14Jun20
 - baculum: Add date and time formatters - idea proposed by Wanderlei Huttel

13Jun20
 - baculum: Enable re-running jobs in async way and visual improvements

12Jun20
 - baculum: Change cursor over selectable table

11Jun20
 - Fix build script copyright detection
 - release: add code to detect Bacula Systems copyrights and fail release

03Jun19
 - Fix compilation of bsnapshot on Fedora

Bugs fixed/closed since last release:
2558 6366


=================================================
Release 9.6.4

08Jun20
 - Add configure variables to baculabackupreport. Patch from bug #2538
 - Fix orphaned buffers in cloud by adding truncate argument to end_of_job()

06Jun20
 - Improve clarity of Cloud part mismatches and make it an INFO message rather
  than a WARNING since it corrects the catalog.
 - Small trivial change to check_parts

05Jun20
 - Backport more Enterprise cloud parts changes
 - Backport cloud upload code from Enterprise

03Jun20
 - Update s3_driver.c to new libs3 API calling sequence

02Jun20
 - Fix tray-monitor installation
 - Recompile ./configure
 - Add ./configure code to check for and enable/disable S3 support
 - win32: Fix org#2547 About possible NULL pointer dereference in get_memory_info
 - Ensure cloud driver loaded when listing cloud volumes

29May20
 - baculum: Request #2546 support for full restore when file records for backup
  job are pruned

25May20
 - baculum: Fix problem with authorization error after upgrade
 - baculum: Add UPGRADE file

24May20
 - baculum: Fix returning value in TStyleDiff - generated notice with PHP
  7.4
 - baculum: Remove execute bit for framework scripts

22May20
 - baculum: Fix displaying empty column button in table column visibility menu -
  reported by Wanderlei Huttel

21May20
 - baculum: Update Polish translations
 - baculum: Update Portuguese translations

19May20
 - baculum: New user management. LDAP support. Role-based access control.

12May20
 - Fix new compiler warnings + always use bstrncpy not strncpy to ensure EOS at
  end of string

11May20
 - Return smartalloc buffers zeroed -- future performance improvement

10May20
 - Improve scanning data/time, fixes bug #2472
 - Make ABORT mention segfault to clarify non-bug #2528
 - Make reading a short block a warning rather than error

09May20
 - baculum: Fix validators in run job modal window

02May20
 - Remove unused -t option in dbcheck.c -- fixes bug #2453

01May20
 - Fix bug 2523 -- spurious extra linking
 - Fix bug #2534 possible double free in error case
 - Fix possible sscanf overflows
 - Fix overflow from malicious FD reported by Pasi Saarinen

18Apr20
 - baculum: Add option to show time in job log - idea proposed by Wanderlei
  Huttel
 - baculum: Add show log time parameter to job log endpoint

16Apr20
 - baculum: Add tip about using table row selection

17Mar20
 - Fix bug #2525 seg fault when doing estimate with accurate and MD5
 - baculum: Fix issues with SELinux support reported by Neil MacGregor

16Mar20
 - Correct some copyrights

07Mar20
 - Add Docker plugin rpm spec files

Bugs fixed/closed since last release:
2453 2472 2525 2528 2534 2546 2547

===========================================================

Release Version 9.6.3
09Mar20
 - Eliminate false error when droping postgres table MAC
 - Apply Carsten's character set fix for the docs. Many thanks!

08Mar20
 - Fix logic error in clearing bit on Windows

07Mar20
 - baculum: Update Portuguese translations
 - baculum: Update Polish translations
 - baculum: Add patch to PRADO framework 4.0.1 for supporting PostgreSQL 12
  catalog database
 - baculum: Add support for PostgreSQL 12 catalog database
 - Enhance failed bpipe to changer error message
 - Clean up some incorrect copyrights
 - Correct spelling errors in messages
 - Add to plugins links

01Mar20
 - baculum: Add bulk actions for job history and volume tables
 - baculum: Update DataTables and its plugins

27Feb20
 - docker: Update copyright headers.
 - Update BSD copyright on *.conf.in files
 - docker: Remove unneeded tar binary.
 - Fix workaround for Sun C++ recommended by Phil Stracchino
 - baculum: Update Polish translations
 - baculum: Update Portuguese translations
2020-12-02 01:36:48 +00:00

82 lines
4.3 KiB
Text

$NetBSD: patch-src_stored_Makefile.in,v 1.3 2020/12/02 01:36:49 jnemeth Exp $
- use %%EXAMPLESDIR%% instead of sysconfdir
- use the .la files for linking
--- src/stored/Makefile.in.orig 2020-09-21 12:30:41.000000000 +0000
+++ src/stored/Makefile.in
@@ -97,7 +97,7 @@ ZLIBS=@ZLIBS@
LZO_LIBS= @LZO_LIBS@
LZO_INC= @LZO_INC@
-SD_LIBS = -lbacsd -lbaccfg -lbac
+SD_LIBS = libbacsd.la ../lib/libbaccfg.la ../lib/libbac.la
.SUFFIXES: .c .o .lo
@@ -155,7 +155,7 @@ bacula-sd-aligned-driver.la: Makefile $(
bsdjson: Makefile $(JSONOBJS) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
@echo "Linking $@ ..."
$(LIBTOOL_LINK) $(CXX) $(WLDFLAGS) $(LDFLAGS) -L../lib -o $@ $(JSONOBJS) $(ZLIBS) \
- -lbaccfg -lbac -lm $(DLIB) $(LIBS) $(WRAPLIBS) \
+ ../lib/libbaccfg.la ../lib/libbac.la -lm $(DLIB) $(LIBS) $(WRAPLIBS) \
$(GETTEXT_LIBS) $(OPENSSL_LIBS) $(CAP_LIBS)
static-bacula-sd: Makefile $(SDOBJS) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
@@ -191,7 +191,7 @@ bls.o: bls.c
bls: Makefile $(BLSOBJS) libbacsd.la $(DRIVERS) ../findlib/libbacfind$(DEFAULT_ARCHIVE_TYPE) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
@echo "Linking $@ ..."
$(LIBTOOL_LINK) $(CXX) $(TTOOL_LDFLAGS) $(LDFLAGS) -L../lib -L../findlib -o $@ $(BLSOBJS) $(DLIB) \
- $(SD_LIBS) -lbacfind -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
+ $(SD_LIBS) ../findlib/libbacfind.la -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
bextract.o: bextract.c
@echo "Compiling $<"
@@ -201,7 +201,7 @@ bextract.o: bextract.c
bextract: Makefile $(BEXTOBJS) libbacsd.la $(DRIVERS) ../findlib/libbacfind$(DEFAULT_ARCHIVE_TYPE) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
@echo "Linking $@ ..."
$(LIBTOOL_LINK) $(CXX) $(TTOOL_LDFLAGS) $(LDFLAGS) -L../lib -L../findlib -o $@ $(BEXTOBJS) $(DLIB) $(ZLIBS) $(LZO_LIBS) \
- $(SD_LIBS) -lbacfind -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
+ $(SD_LIBS) ../findlib/libbacfind.la -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
bscan.o: bscan.c
@echo "Compiling $<"
@@ -211,7 +211,7 @@ bscan.o: bscan.c
bscan: Makefile $(SCNOBJS) libbacsd.la $(DRIVERS) ../findlib/libbacfind$(DEFAULT_ARCHIVE_TYPE) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) \
../cats/libbacsql$(DEFAULT_ARCHIVE_TYPE) ../cats/libbaccats$(DEFAULT_ARCHIVE_TYPE)
$(LIBTOOL_LINK) $(CXX) $(TTOOL_LDFLAGS) $(LDFLAGS) -L../lib -L../cats -L../findlib -o $@ $(SCNOBJS) \
- $(SD_LIBS) -lbacsql -lbaccats $(DB_LIBS) $(ZLIBS) -lbacfind -lbaccfg -lbac -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
+ $(SD_LIBS) ../cats/libbacsql.la ../cats/libbaccats.la $(DB_LIBS) $(ZLIBS) ../findlib/libbacfind.la ../lib/libbaccfg.la ../lib/libbac.la -lm $(LIBS) $(GETTEXT_LIBS) $(OPENSSL_LIBS)
bcopy.o: bcopy.c
@echo "Compiling $<"
@@ -225,7 +225,7 @@ bcopy: Makefile $(COPYOBJS) libbacsd.la
cloud_parts_test: Makefile cloud_parts.c
$(RMF) cloud_parts.o
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) cloud_parts.c
- $(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ cloud_parts.o $(DLIB) -lbac -lm $(LIBS) $(OPENSSL_LIBS)
+ $(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -L../lib -o $@ cloud_parts.o $(DLIB) ../lib/libbac.la -lm $(LIBS) $(OPENSSL_LIBS)
rm -f cloud_parts.o
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) cloud_parts.c
@@ -254,16 +254,16 @@ install: all @LIBTOOL_INSTALL_TARGET@
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-sd $(DESTDIR)$(sbindir)/static-bacula-sd; \
fi
@srcconf=bacula-sd.conf; \
- if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
+ if test -f ${DESTDIR}%%EXAMPLESDIR%%/$$srcconf; then \
destconf=$$srcconf.new; \
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
else \
destconf=$$srcconf; \
fi; \
- echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
- ${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
+ echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf"; \
+ ${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf
@if test "x${sd_group}" != "x" -a "x${DESTDIR}" = "x" ; then \
- chgrp -f ${sd_group} ${DESTDIR}${sysconfdir}/$$destconf; \
+ chgrp -f ${sd_group} ${DESTDIR}%%EXAMPLESDIR%%/$$destconf; \
fi
install-cloud: bacula-sd-cloud-driver.la