Configuration * By default HDF4 libraries and utilities are installed under <source_dir>/NewHDF * Windows configuration, build and testing procedures have been changed. Please see INSTALL_WINDOWS.txt file for more information Library * New API SDidtype was added to the library (bug #766) * HCgetcompress renamed to HCPgetcompress * New API HCget_config_info added * The default chunk cache size was changed for 2D and higher chunks * Pablo instumentation was removed Utilities * hdiff and hrepack are supported on Windows. * Substantial performance improvements in hdiff and hrepack Support for new platforms and compilers * Fortran IBM xlf v 8.1 and Absoft f95 version 8.2 compilers are supported on Mac OSX. * Absoft Fortran compiler f95 version 9.0 is supported on Linux 2.4 * PGI C and Fortran compilers are supported on Linux 2.4 * Intel C and Fortran compilers are supported on Linux 2.4 * Cray TS IEEE is supported. Bugs fixed since HDF4.2r0 * VERY IMPORTANT: Data compressed with SZIP may be corrupted; fixed. For more information see "HDF4.2r1 SZIP Release Notes" available at http://hdf.ncsa.uiuc.edu/doc_resource/SZIP/SZIP_HDF4_2r1.pdf * Fortran couldn't read names with spaces when NetCDF interfaces were used; fixed * Library failed to compile in presence of the NetCDF library; fixed * h4fc couldn't create object files; fixed * When rank of SDS is 0, some SD APIs give segmentation fault (bug 1045); fixed * Some GR images with special elements are read in as duplicate (bug 814); fixed * Many bugs fixed in hdiff and hrepack utilities
58 lines
2.5 KiB
Text
58 lines
2.5 KiB
Text
$NetBSD: patch-aj,v 1.7 2005/02/24 16:25:38 adam Exp $
|
|
|
|
--- mfhdf/ncgen/Makefile.in.orig 2004-12-06 23:20:34.000000000 +0000
|
|
+++ mfhdf/ncgen/Makefile.in
|
|
@@ -169,7 +169,7 @@ ncgen_DEPENDENCIES = $(top_builddir)/hdf
|
|
|
|
#############################################################################
|
|
#############################################################################
|
|
-man1_MANS = ncgen.1
|
|
+man1_MANS = hdfncgen.1
|
|
|
|
|
|
#############################################################################
|
|
@@ -188,7 +188,7 @@ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
mkinstalldirs = $(SHELL) $(top_srcdir)/bin/mkinstalldirs
|
|
CONFIG_HEADER = $(top_builddir)/hdf/src/h4config.h
|
|
CONFIG_CLEAN_FILES =
|
|
-bin_PROGRAMS = ncgen$(EXEEXT)
|
|
+bin_PROGRAMS = hdfncgen$(EXEEXT)
|
|
@HDF_BUILD_FORTRAN_TRUE@noinst_PROGRAMS = ctest0$(EXEEXT) \
|
|
@HDF_BUILD_FORTRAN_TRUE@ ftest0$(EXEEXT)
|
|
@HDF_BUILD_FORTRAN_FALSE@noinst_PROGRAMS = ctest0$(EXEEXT)
|
|
@@ -269,7 +269,7 @@ clean-noinstPROGRAMS:
|
|
@HDF_BUILD_FORTRAN_FALSE@ftest0$(EXEEXT): $(ftest0_OBJECTS) $(ftest0_DEPENDENCIES)
|
|
@HDF_BUILD_FORTRAN_FALSE@ @rm -f ftest0$(EXEEXT)
|
|
@HDF_BUILD_FORTRAN_FALSE@ $(LINK) $(ftest0_LDFLAGS) $(ftest0_OBJECTS) $(ftest0_LDADD) $(LIBS)
|
|
-ncgen$(EXEEXT): $(ncgen_OBJECTS) $(ncgen_DEPENDENCIES)
|
|
+hdfncgen$(EXEEXT): $(ncgen_OBJECTS) $(ncgen_DEPENDENCIES)
|
|
@rm -f ncgen$(EXEEXT)
|
|
$(LINK) $(ncgen_LDFLAGS) $(ncgen_OBJECTS) $(ncgen_LDADD) $(LIBS)
|
|
|
|
@@ -581,8 +581,8 @@ c-check: test2.cdl ctest0
|
|
@HDF_BUILD_FORTRAN_TRUE@ echo "*** ncgen -f test failed (but roundoff differences are OK) ***"; \
|
|
@HDF_BUILD_FORTRAN_TRUE@ fi
|
|
|
|
-@HDF_BUILD_FORTRAN_TRUE@ftest0: ncgen test0.cdl netcdf.inc
|
|
-@HDF_BUILD_FORTRAN_TRUE@ ./ncgen -f -o ftest0.nc $(srcdir)/test0.cdl > test0.f
|
|
+@HDF_BUILD_FORTRAN_TRUE@ftest0: hdfncgen test0.cdl netcdf.inc
|
|
+@HDF_BUILD_FORTRAN_TRUE@ ./hdfncgen -f -o ftest0.nc $(srcdir)/test0.cdl > test0.f
|
|
@HDF_BUILD_FORTRAN_TRUE@ $(F77) $(FFLAGS) -o $@ test0.f $(LDFLAGS) $(ncgen_LDADD) $(LIBS)
|
|
|
|
netcdf.inc:
|
|
@@ -591,11 +591,11 @@ netcdf.inc:
|
|
test1.cdl: test0.nc
|
|
$(NCDUMP) -n test1 test0.nc > $@
|
|
|
|
-test0.nc: ncgen $(srcdir)/test0.cdl
|
|
- ./ncgen -b -o test0.nc $(srcdir)/test0.cdl
|
|
+test0.nc: hdfncgen $(srcdir)/test0.cdl
|
|
+ ./hdfncgen -b -o test0.nc $(srcdir)/test0.cdl
|
|
|
|
-ctest0: ncgen $(srcdir)/test0.cdl
|
|
- ./ncgen -c -o ctest0.nc $(srcdir)/test0.cdl > test0.c
|
|
+ctest0: hdfncgen $(srcdir)/test0.cdl
|
|
+ ./hdfncgen -c -o ctest0.nc $(srcdir)/test0.cdl > test0.c
|
|
$(COMPILE) -o $@ test0.c $(LDFLAGS) $(ncgen_LDADD) $(LIBS)
|
|
|
|
#############################################################################
|