d1d63b11a9
* improved sftp backend with symlink info retrieving (readlink). * new cls option -a to show dot files. * new setting cmd:cls-exact-time. * fixed NULL dereference when torrent:use-dht is off. * fixed torrent for info_hash with NUL character (broken in 4.4.4).
37 lines
1.5 KiB
Text
37 lines
1.5 KiB
Text
$NetBSD: patch-aa,v 1.18 2013/05/18 20:23:03 adam Exp $
|
|
|
|
Do not install by default Perl scripts; they are installed via
|
|
${INSTALL_SCRIPT} if the user set the "perl" option.
|
|
|
|
Do not remove the *.la files.
|
|
|
|
--- src/Makefile.in.orig 2013-05-17 10:02:35.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -1567,7 +1567,7 @@ top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
pkgverlibdir = $(pkglibdir)/$(VERSION)
|
|
bin_SCRIPTS = lftpget
|
|
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-mozilla-cookies xdg-move
|
|
+pkgdata_SCRIPTS = import-ncftp import-netscape xdg-move
|
|
noinst_SCRIPTS = ftpget
|
|
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS)
|
|
lftp_SOURCES = lftp.cc complete.h complete.cc lftp_rl.c lftp_rl.h attach.cc attach.h
|
|
@@ -2201,7 +2201,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
|
|
install-binPROGRAMS: install-libLTLIBRARIES
|
|
|
|
installdirs:
|
|
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgverlibdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
|
|
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
|
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
done
|
|
install: install-am
|
|
@@ -2337,6 +2337,9 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
# libtool does not strip modules, do it here.
|
|
install-data-hook:
|
|
+ :
|
|
+
|
|
+install-data-hook-disabled:
|
|
@WITH_MODULES_TRUE@ rm -f $(DESTDIR)$(pkgverlibdir)/*.la; \
|
|
@WITH_MODULES_TRUE@ case " $(LDFLAGS) " in *" -s "*) \
|
|
@WITH_MODULES_TRUE@ $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so;; \
|