pkgsrc/audio/jack/patches/patch-ad
bjs 1d500c5f48 Update to jack-0.115.1 (from SVN). Changes: pulled in a patch
to [hopefully] correct errant behavior wrt: non-blocking I/O and sockets.
This is presently untested, however.  Also, with this snapshot
we at least have the hope that the network facility works.  Includes
other miscellaneous bug fixes, also.

While here, explicitly enable coreaudio on Darwin and add a PLIST
entry for its driver module.  This is also untested, but at least
installation on Darwin will not fail due to an incorrect PLIST.  Also,
include ../../mk/dlopen.buildlink3.mk in our bl3.mk in order
to heed DLOPEN_REQUIRE_PTHREADS.
2008-11-16 11:22:55 +00:00

16 lines
426 B
Text

$NetBSD: patch-ad,v 1.2 2008/11/16 11:22:55 bjs Exp $
--- drivers/oss/oss_driver.h.orig 2008-11-11 17:36:43.000000000 -0500
+++ drivers/oss/oss_driver.h
@@ -34,7 +34,11 @@
#include <jack/jack.h>
+#if defined(DEVOSSAUDIO)
+#define OSS_DRIVER_DEF_DEV DEVOSSAUDIO
+#else
#define OSS_DRIVER_DEF_DEV "/dev/dsp"
+#endif
#define OSS_DRIVER_DEF_FS 48000
#define OSS_DRIVER_DEF_BLKSIZE 1024
#define OSS_DRIVER_DEF_NPERIODS 2