1d500c5f48
to [hopefully] correct errant behavior wrt: non-blocking I/O and sockets. This is presently untested, however. Also, with this snapshot we at least have the hope that the network facility works. Includes other miscellaneous bug fixes, also. While here, explicitly enable coreaudio on Darwin and add a PLIST entry for its driver module. This is also untested, but at least installation on Darwin will not fail due to an incorrect PLIST. Also, include ../../mk/dlopen.buildlink3.mk in our bl3.mk in order to heed DLOPEN_REQUIRE_PTHREADS.
28 lines
889 B
Text
28 lines
889 B
Text
$NetBSD: patch-ak,v 1.2 2008/11/16 11:22:55 bjs Exp $
|
|
|
|
Yuck. At least let's attempt to make this somewhat sane.
|
|
When I have the time and figure out the Right Thing(tm)
|
|
to do, perhaps I'll rewrite some of the shm code.
|
|
|
|
--- libjack/unlock.c.orig 2008-11-11 17:36:29.000000000 -0500
|
|
+++ libjack/unlock.c
|
|
@@ -44,8 +44,9 @@ static char* whitelist[] = {
|
|
static char* library_roots[] = {
|
|
"/lib",
|
|
"/usr/lib",
|
|
+ "@PREFIX@", /* pkgsrc prefix */
|
|
+ "@X11PREFIX@/lib",
|
|
"/usr/local/lib",
|
|
- "/usr/X11R6/lib",
|
|
"/opt/lib", /* solaris-y */
|
|
"/opt/local/lib", /* common on OS X */
|
|
NULL
|
|
@@ -63,7 +64,7 @@ cleanup_mlock ()
|
|
int whoknows;
|
|
int looks_like_library;
|
|
|
|
- snprintf (path, sizeof(path), "/proc/%d/maps", getpid());
|
|
+ snprintf (path, sizeof(path), "@JACKD_PROCFS_PATH@/%d/maps", getpid());
|
|
|
|
if ((map = fopen (path, "r")) == NULL) {
|
|
jack_error ("can't open map file");
|