pkgsrc/x11/libX11/patches/patch-ac
joerg e12cfc4e1a Update to libX11-1.3.5:
- Enable XCB support [pkgsrc]

- Improve I18N support
- Various bug fixes, including use-after-free and XCB thread fixes
2010-09-10 20:28:03 +00:00

607 lines
18 KiB
Text

$NetBSD: patch-ac,v 1.10 2010/09/10 20:28:03 joerg Exp $
See patch-aa.
--- configure.orig 2010-08-11 23:24:54.000000000 +0000
+++ configure
@@ -828,28 +828,22 @@ ac_ct_DUMPBIN
DUMPBIN
LD
FGREP
+SED
LIBTOOL
HAVE_PS2PDF_FALSE
HAVE_PS2PDF_TRUE
PS2PDF
-HAVE_GROFF_HTML_FALSE
-HAVE_GROFF_HTML_TRUE
HAVE_GROFF_MM_FALSE
HAVE_GROFF_MM_TRUE
HAVE_GROFF_MS_FALSE
HAVE_GROFF_MS_TRUE
HAVE_GROFF_FALSE
HAVE_GROFF_TRUE
-PSSELECT_PATH
-PNMTOPNG_PATH
-GS_PATH
GROFF
ENABLE_SPECS_FALSE
ENABLE_SPECS_TRUE
AM_BACKSLASH
AM_DEFAULT_VERBOSITY
-MAN_SUBSTS
-XORG_MAN_PAGE
ADMIN_MAN_DIR
DRIVER_MAN_DIR
MISC_MAN_DIR
@@ -862,7 +856,6 @@ MISC_MAN_SUFFIX
FILE_MAN_SUFFIX
LIB_MAN_SUFFIX
APP_MAN_SUFFIX
-SED
INSTALL_CMD
PKG_CONFIG
CHANGELOG_CMD
@@ -964,6 +957,7 @@ enable_option_checking
enable_maintainer_mode
enable_dependency_tracking
enable_strict_compilation
+with_release_version
enable_silent_rules
enable_specs
with_groff
@@ -1014,8 +1008,6 @@ XDMCP_CFLAGS
XDMCP_LIBS
BIGFONT_CFLAGS
BIGFONT_LIBS
-LINT
-LINT_FLAGS
X11_CFLAGS
X11_LIBS'
@@ -1677,6 +1669,8 @@ Optional Features:
Optional Packages:
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
+ --with-release-version=STRING
+ Use release version string in package name
--with-groff Use groff to regenerate documentation (default: yes,
if installed)
--with-ps2pdf Use ps2pdf to regenerate documentation (default:
@@ -1716,8 +1710,6 @@ Some influential environment variables:
C compiler flags for BIGFONT, overriding pkg-config
BIGFONT_LIBS
linker flags for BIGFONT, overriding pkg-config
- LINT Path to a lint-style command
- LINT_FLAGS Flags for the lint-style command
X11_CFLAGS C compiler flags for X11, overriding pkg-config
X11_LIBS linker flags for X11, overriding pkg-config
@@ -5010,76 +5002,6 @@ $as_echo "no" >&6; }
fi
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for a sed that does not truncate output" >&5
-$as_echo_n "checking for a sed that does not truncate output... " >&6; }
-if test "${ac_cv_path_SED+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- ac_script=s/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa/bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb/
- for ac_i in 1 2 3 4 5 6 7; do
- ac_script="$ac_script$as_nl$ac_script"
- done
- echo "$ac_script" 2>/dev/null | sed 99q >conftest.sed
- { ac_script=; unset ac_script;}
- if test -z "$SED"; then
- ac_path_SED_found=false
- # Loop through the user's path and test for each of PROGNAME-LIST
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_prog in sed gsed; do
- for ac_exec_ext in '' $ac_executable_extensions; do
- ac_path_SED="$as_dir/$ac_prog$ac_exec_ext"
- { test -f "$ac_path_SED" && $as_test_x "$ac_path_SED"; } || continue
-# Check for GNU ac_path_SED and select it if it is found.
- # Check for GNU $ac_path_SED
-case `"$ac_path_SED" --version 2>&1` in
-*GNU*)
- ac_cv_path_SED="$ac_path_SED" ac_path_SED_found=:;;
-*)
- ac_count=0
- $as_echo_n 0123456789 >"conftest.in"
- while :
- do
- cat "conftest.in" "conftest.in" >"conftest.tmp"
- mv "conftest.tmp" "conftest.in"
- cp "conftest.in" "conftest.nl"
- $as_echo '' >> "conftest.nl"
- "$ac_path_SED" -f conftest.sed < "conftest.nl" >"conftest.out" 2>/dev/null || break
- diff "conftest.out" "conftest.nl" >/dev/null 2>&1 || break
- as_fn_arith $ac_count + 1 && ac_count=$as_val
- if test $ac_count -gt ${ac_path_SED_max-0}; then
- # Best one so far, save it but keep looking for a better one
- ac_cv_path_SED="$ac_path_SED"
- ac_path_SED_max=$ac_count
- fi
- # 10*(2^10) chars as input seems more than enough
- test $ac_count -gt 10 && break
- done
- rm -f conftest.in conftest.tmp conftest.nl conftest.out;;
-esac
-
- $ac_path_SED_found && break 3
- done
- done
- done
-IFS=$as_save_IFS
- if test -z "$ac_cv_path_SED"; then
- as_fn_error "no acceptable sed could be found in \$PATH" "$LINENO" 5
- fi
-else
- ac_cv_path_SED=$SED
-fi
-
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_path_SED" >&5
-$as_echo "$ac_cv_path_SED" >&6; }
- SED="$ac_cv_path_SED"
- rm -f conftest.sed
-
-
@@ -5107,7 +5029,7 @@ fi
-# If the module's configure.ac calls AC_PROG_CC later on, CC gets set to C89
+
@@ -5146,6 +5068,20 @@ CWARNFLAGS="$CWARNFLAGS $STRICT_CFLAGS"
+# Check whether --with-release-version was given.
+if test "${with_release_version+set}" = set; then :
+ withval=$with_release_version; RELEASE_VERSION="$withval"
+else
+ RELEASE_VERSION=""
+fi
+
+ if test "x$RELEASE_VERSION" != "x"; then
+ PACKAGE="$PACKAGE-$RELEASE_VERSION"
+ PACKAGE_TARNAME="$PACKAGE_TARNAME-$RELEASE_VERSION"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: Building with package name set to $PACKAGE" >&5
+$as_echo "$as_me: Building with package name set to $PACKAGE" >&6;}
+ fi
+
cat >>confdefs.h <<_ACEOF
#define PACKAGE_VERSION_MAJOR `echo $PACKAGE_VERSION | cut -d . -f 1`
_ACEOF
@@ -5188,7 +5124,6 @@ echo 'util-macros \"pkgdatadir\" from xo
-
if test x$APP_MAN_SUFFIX = x ; then
APP_MAN_SUFFIX=1
fi
@@ -5257,23 +5192,6 @@ fi
-XORG_MAN_PAGE="X Version 11"
-
-MAN_SUBSTS="\
- -e 's|__vendorversion__|\"\$(PACKAGE_STRING)\" \"\$(XORG_MAN_PAGE)\"|' \
- -e 's|__xorgversion__|\"\$(PACKAGE_STRING)\" \"\$(XORG_MAN_PAGE)\"|' \
- -e 's|__xservername__|Xorg|g' \
- -e 's|__xconfigfile__|xorg.conf|g' \
- -e 's|__projectroot__|\$(prefix)|g' \
- -e 's|__appmansuffix__|\$(APP_MAN_SUFFIX)|g' \
- -e 's|__drivermansuffix__|\$(DRIVER_MAN_SUFFIX)|g' \
- -e 's|__adminmansuffix__|\$(ADMIN_MAN_SUFFIX)|g' \
- -e 's|__libmansuffix__|\$(LIB_MAN_SUFFIX)|g' \
- -e 's|__miscmansuffix__|\$(MISC_MAN_SUFFIX)|g' \
- -e 's|__filemansuffix__|\$(FILE_MAN_SUFFIX)|g'"
-
-
-
# Check whether --enable-silent-rules was given.
if test "${enable_silent_rules+set}" = set; then :
enableval=$enable_silent_rules;
@@ -5425,7 +5343,6 @@ $as_echo "$as_me: WARNING: ignoring GROF
else
as_fn_error "--with-groff expects 'yes' or 'no'" "$LINENO" 5
fi
-
# We have groff, test for the presence of the macro packages
if test "x$have_groff" = x"yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ${GROFF} -ms macros" >&5
@@ -5447,144 +5364,6 @@ $as_echo_n "checking for ${GROFF} -mm ma
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $groff_mm_works" >&5
$as_echo "$groff_mm_works" >&6; }
fi
-
-# We have groff, test for HTML dependencies, one command per package
-if test "x$have_groff" = x"yes"; then
- for ac_prog in gs gswin32c
-do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
-set dummy $ac_prog; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if test "${ac_cv_path_GS_PATH+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- case $GS_PATH in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_GS_PATH="$GS_PATH" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_GS_PATH="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-GS_PATH=$ac_cv_path_GS_PATH
-if test -n "$GS_PATH"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GS_PATH" >&5
-$as_echo "$GS_PATH" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
- test -n "$GS_PATH" && break
-done
-
- # Extract the first word of "pnmtopng", so it can be a program name with args.
-set dummy pnmtopng; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if test "${ac_cv_path_PNMTOPNG_PATH+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- case $PNMTOPNG_PATH in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_PNMTOPNG_PATH="$PNMTOPNG_PATH" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_PNMTOPNG_PATH="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-PNMTOPNG_PATH=$ac_cv_path_PNMTOPNG_PATH
-if test -n "$PNMTOPNG_PATH"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PNMTOPNG_PATH" >&5
-$as_echo "$PNMTOPNG_PATH" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
- # Extract the first word of "psselect", so it can be a program name with args.
-set dummy psselect; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if test "${ac_cv_path_PSSELECT_PATH+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- case $PSSELECT_PATH in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_PSSELECT_PATH="$PSSELECT_PATH" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_PSSELECT_PATH="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-PSSELECT_PATH=$ac_cv_path_PSSELECT_PATH
-if test -n "$PSSELECT_PATH"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PSSELECT_PATH" >&5
-$as_echo "$PSSELECT_PATH" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
- if test "x$GS_PATH" != "x" -a "x$PNMTOPNG_PATH" != "x" -a "x$PSSELECT_PATH" != "x"; then
- have_groff_html=yes
- else
- have_groff_html=no
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: grohtml dependencies not found - HTML Documentation skipped. Refer to grohtml man pages" >&5
-$as_echo "$as_me: WARNING: grohtml dependencies not found - HTML Documentation skipped. Refer to grohtml man pages" >&2;}
- fi
-fi
-
-# Set Automake conditionals for Makefiles
if test "$have_groff" = yes; then
HAVE_GROFF_TRUE=
HAVE_GROFF_FALSE='#'
@@ -5609,14 +5388,6 @@ else
HAVE_GROFF_MM_FALSE=
fi
- if test "$have_groff_html" = yes; then
- HAVE_GROFF_HTML_TRUE=
- HAVE_GROFF_HTML_FALSE='#'
-else
- HAVE_GROFF_HTML_TRUE='#'
- HAVE_GROFF_HTML_FALSE=
-fi
-
@@ -14431,43 +14202,18 @@ $as_echo "#define XUSE_MTSAFE_API 1" >>c
;;
esac
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pthread_self in -lc" >&5
-$as_echo_n "checking for pthread_self in -lc... " >&6; }
-if test "${ac_cv_lib_c_pthread_self+set}" = set; then :
- $as_echo_n "(cached) " >&6
+ac_fn_c_check_decl "$LINENO" "pthread_self" "ac_cv_have_decl_pthread_self" "#include <pthread.h>
+"
+if test "x$ac_cv_have_decl_pthread_self" = x""yes; then :
+ ac_have_decl=1
else
- ac_check_lib_save_LIBS=$LIBS
-LIBS="-lc $LIBS"
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
+ ac_have_decl=0
+fi
-/* Override any GCC internal prototype to avoid an error.
- Use char because int might match the return type of a GCC
- builtin and then its argument prototype would still apply. */
-#ifdef __cplusplus
-extern "C"
-#endif
-char pthread_self ();
-int
-main ()
-{
-return pthread_self ();
- ;
- return 0;
-}
+cat >>confdefs.h <<_ACEOF
+#define HAVE_DECL_PTHREAD_SELF $ac_have_decl
_ACEOF
-if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_lib_c_pthread_self=yes
-else
- ac_cv_lib_c_pthread_self=no
-fi
-rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
-LIBS=$ac_check_lib_save_LIBS
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_c_pthread_self" >&5
-$as_echo "$ac_cv_lib_c_pthread_self" >&6; }
-if test "x$ac_cv_lib_c_pthread_self" = x""yes; then :
+if test $ac_have_decl = 1; then :
thrstubs="no"
else
thrstubs="yes"
@@ -14487,8 +14233,8 @@ if test x$xthreads = xyes ; then
linux*|openbsd*|gnu*|k*bsd*-gnu)
XTHREADLIB=-lpthread ;;
netbsd*)
- XTHREAD_CFLAGS="-D_POSIX_THREAD_SAFE_FUNCTIONS"
- XTHREADLIB="-lpthread" ;;
+ XTHREAD_CFLAGS="-D_REENTRANT"
+ XTHREADLIB="-pthread" ;;
freebsd*)
XTHREAD_CFLAGS="-D_THREAD_SAFE"
XTHREADLIB="-pthread" ;;
@@ -14960,8 +14706,7 @@ fi
-
-
+# Allow checking code with lint, sparse, etc.
# Check whether --with-lint was given.
if test "${with_lint+set}" = set; then :
@@ -14970,86 +14715,26 @@ else
use_lint=no
fi
-
-# Obtain platform specific info like program name and options
-# The lint program on FreeBSD and NetBSD is different from the one on Solaris
-case $host_os in
- *linux* | *openbsd* | kfreebsd*-gnu | darwin* | cygwin*)
- lint_name=splint
- lint_options="-badflag"
- ;;
- *freebsd* | *netbsd*)
- lint_name=lint
- lint_options="-u -b"
- ;;
- *solaris*)
- lint_name=lint
- lint_options="-u -b -h -erroff=E_INDISTING_FROM_TRUNC2"
- ;;
-esac
-
-# Test for the presence of the program (either guessed by the code or spelled out by the user)
-if test "x$use_lint" = x"yes" ; then
- # Extract the first word of "$lint_name", so it can be a program name with args.
-set dummy $lint_name; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if test "${ac_cv_path_LINT+set}" = set; then :
- $as_echo_n "(cached) " >&6
-else
- case $LINT in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_LINT="$LINT" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_LINT="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-LINT=$ac_cv_path_LINT
-if test -n "$LINT"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $LINT" >&5
-$as_echo "$LINT" >&6; }
+if test "x$use_lint" = "xyes" ; then
+ LINT="lint"
else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
+ LINT="$use_lint"
fi
-
-
- if test "x$LINT" = "x"; then
- as_fn_error "--with-lint=yes specified but lint-style tool not found in PATH" "$LINENO" 5
- fi
-elif test "x$use_lint" = x"no" ; then
- if test "x$LINT" != "x"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: ignoring LINT environment variable since --with-lint=no was specified" >&5
-$as_echo "$as_me: WARNING: ignoring LINT environment variable since --with-lint=no was specified" >&2;}
- fi
-else
- as_fn_error "--with-lint expects 'yes' or 'no'. Use LINT variable to specify path." "$LINENO" 5
+if test "x$LINT_FLAGS" = "x" -a "x$LINT" != "xno" ; then
+ case $LINT in
+ lint|*/lint)
+ case $host_os in
+ solaris*)
+ LINT_FLAGS="-u -b -h -erroff=E_INDISTING_FROM_TRUNC2"
+ ;;
+ esac
+ ;;
+ esac
fi
-# User supplied flags override default flags
-if test "x$LINT_FLAGS" != "x"; then
- lint_options=$LINT_FLAGS
-fi
-LINT_FLAGS=$lint_options
- if test "x$LINT" != x; then
+ if test x$LINT != xno; then
LINT_TRUE=
LINT_FALSE='#'
else
@@ -15061,6 +14746,7 @@ fi
+# Build lint "library" for more indepth checks of programs calling this library
# Check whether --enable-lint-library was given.
if test "${enable_lint_library+set}" = set; then :
enableval=$enable_lint_library; make_lint_lib=$enableval
@@ -15068,17 +14754,17 @@ else
make_lint_lib=no
fi
-
-if test "x$make_lint_lib" = x"yes" ; then
- LINTLIB=llib-lX11.ln
- if test "x$LINT" = "x"; then
- as_fn_error "Cannot make lint library without --with-lint" "$LINENO" 5
- fi
-elif test "x$make_lint_lib" != x"no" ; then
- as_fn_error "--enable-lint-library expects 'yes' or 'no'." "$LINENO" 5
+if test "x$make_lint_lib" != "xno" ; then
+ if test "x$LINT" = "xno" ; then
+ as_fn_error "Cannot make lint library without --with-lint" "$LINENO" 5
+ fi
+ if test "x$make_lint_lib" = "xyes" ; then
+ LINTLIB=llib-lX11.ln
+ else
+ LINTLIB=$make_lint_lib
+ fi
fi
-
if test x$make_lint_lib != xno; then
MAKE_LINT_LIB_TRUE=
MAKE_LINT_LIB_FALSE='#'
@@ -15524,10 +15210,6 @@ if test -z "${HAVE_GROFF_MM_TRUE}" && te
as_fn_error "conditional \"HAVE_GROFF_MM\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
fi
-if test -z "${HAVE_GROFF_HTML_TRUE}" && test -z "${HAVE_GROFF_HTML_FALSE}"; then
- as_fn_error "conditional \"HAVE_GROFF_HTML\" was never defined.
-Usually this means the macro was only invoked conditionally." "$LINENO" 5
-fi
if test -z "${HAVE_PS2PDF_TRUE}" && test -z "${HAVE_PS2PDF_FALSE}"; then
as_fn_error "conditional \"HAVE_PS2PDF\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5